New BUild won't power up

Hello,
I built my first PC yesterrday. All worked fine, loaded os & other software. Was able to use PC for several hours before switching it off. Went to bed (you needed that bit of info, right?) and tried to swith pc on ths morning - nothing except an led power light. PC was switched off and turned off at mains inlet, though the power cable was still attached.

Have tried to power up with only cpu/mobo power - same.

My System:
Intel i5-3570k
Arctic Xtreme cooler
MSI Z77-G45 mobo
8Gb Corsair RAM (2x4Gb)
EVGA GTX 660Ti 3Gb
WD 1Tb Hdd
OCZ Vertex 128Gb SSD
Seasonic M12ii 520 PSU

Win8 x64
All help greatly appreciated before I dismantle and start again.
5 answers Last reply
More about build power
  1. Tried pressing the power button on the mobo?
  2. Thanks: Clear CMOS button or...? I can't find reference to a mobo power button - will searchthe manual & website tho...
  3. Not all have them. Try shorting the power pin header on the mobo?
  4. I love you :love: - sorted tyvm
  5. No problem.
Ask a new question

Read More

Power Supplies Components