Sign in with
Sign up | Sign in
Your question

HP Pavilion dv7-1000 series no bios

Last response: in Components
Share
January 12, 2013 1:39:43 AM

so I'm fixing my friend's HP Pavilion dv7-1000 series. When I turn on the power, the led's go on, but the laptop won't even boot to a bios screen. The led's blink once, over and over and I found this to mean there is an issue with the processor. So I bout a new processor and replaced it, triple checked all the connections, but to no avail. The laptop still won't even boot to bios and I get 1 led blink over and over. Anyone have any advice for me to get this fixed?
January 12, 2013 8:44:08 PM

Yes, checking on this chart I found the CPU to be the reported cause. Even when I replaced the CPU, however, the same LED blink code appears.
Related resources
January 18, 2013 11:35:12 PM

Anyone else have any ideas?
January 19, 2013 10:40:07 PM

kb34rz said:
so I'm fixing my friend's HP Pavilion dv7-1000 series. When I turn on the power, the led's go on, but the laptop won't even boot to a bios screen. The led's blink once, over and over and I found this to mean there is an issue with the processor. So I bout a new processor and replaced it, triple checked all the connections, but to no avail. The laptop still won't even boot to bios and I get 1 led blink over and over. Anyone have any advice for me to get this fixed?


well I had this same problem and i fixed it. it sounds crazy but i took out the motherboard removed the cpu and all wires, then i put it in the oven turned it on to 390f baked it for 15 mins turned off the oven opened the door and let it cool slowly, put it back together and viola it worked. apparently this reflowed the solder. I was searching and found this fix on utube. hey yhe tech guy told my mom this computer was toast and suggested she recycle it. now I have a nice dv7 with bluray player that works great so far. I also downloaded an app called speedfan that speeds up the cooling fan. hey its worth a try and it worked for me. I really couldnt believe it but it is working great now
!