Sign in with
Sign up | Sign in
Your question

hard drive locked?

Last response: in Storage
Share
Anonymous
a b G Storage
September 13, 2001 5:50:05 AM

i have a new quantum lct20 30gig drive that i used to back up my tivo disk. when my ibm drive crashed last weekend, i thought i'd temporarily use the quantum drive in its place. well, i went to fdisk and format it but the drive appeared as an 8 meg drive! i remembered something about a lock feature on the original tivo drive that might have gotten cloned onto this drive, so i ran western digital's dlgchk utility. and upon restart the full disk size is now visible. so i fdisk and format and install win98 and everything is fine, right? wrong. after i shut down and power back up, my system won't boot... and the quantum drive appears as an 8meg drive again. i boot to floppy and run dlgchk then restart... and everything is fine again. so, how do i get rid of whatever is locking this drive everytime power is cycled? please help.

More about : hard drive locked

September 13, 2001 12:41:12 PM

If the problem is software on the drive you should be able to goto Maxtor's website, go under Software & Support//Software and Utils//Maxtor Software Download, and then download the Powermax software. That program is basically diagnostic software, but includes a Low Level Format test. You'll probably want to run that, because it will wipe out everything on the drive including the Master Boot Record.

Is it showing 8MB or 8GB? I just ask, because it's sometimes confused ...

Hope that helps ...

<font color=red>BIOS updates do wonders ....</font color=red>
Anonymous
a b G Storage
September 13, 2001 3:26:59 PM

yes, it is actually showing 8meg (not gig) after a fresh power up. i did do a low level format using powermax and the problem still exists. when i talked to maxtor/quantum support, he suggested i might have some ghost or linux partition on the drive... and that the low level format would erase it. i'm stumped!
Related resources
September 13, 2001 4:43:17 PM

Yeah as far as I know the set-top boxes use a Linux kernal, but the Low Level format should take care of it ...

As long as the system supports the drive make sure you have the drive jumpered correctly (ie DS on) and that you have the BIOS settings usually set to 'Auto' and LBA enabled.

<font color=red>BIOS updates do wonders ....</font color=red>
Anonymous
a b G Storage
September 23, 2001 3:24:33 PM

STILL LOCKED! I tried using a linux boot disk and dd'd the drive with zeros. First, I deleted any and all partitions - just one FAT32 in my case - then did the equivalent of a low level format in linux. It took over 10hrs to complete. So then I fdisk'd and formated in DOS. Restarted and had all 30G visible. I powered down for a few minutes and upon reboot, only 10MEG was visible. When trying to access the drive from DOS it says that it's not ready. So then I reboot using the WD dlgchk utility and of course it says it has trouble accessing this drive. I reboot and all 30G are perfectly visible.

In summary, a fresh power up causes this drive to appear as a 9-10Meg drive and running dlgchk on the drive seems to temporarily fix it back to 30Gig. Where do I go from here?

(Btw, I did recheck bios and jumpers... all is correct.)
March 22, 2009 5:26:11 AM

NO man reseting c-mos wont do anytihng. Lol i ran into same problem and yes there is way to fix it.
Now if you Hard Drive shows up but u cant acess it , its because of lunix partition is corrupted and locked out.

Now Ionly fixed 3 western digital Hd and havent came across with other brand hd.
If its Westrn digital you do this:
Set you HD as master /single (all alone with no slave)
Run Western Digital lifeguard 5.04 or 4.0 pick quick test , Now it should run and say no errors on the drive .(show you that you have no damaged clusters )
Now run Extended Its will say Drive Is locked code Security Enabled.(if it says that) it means you hard disk is not writable or accesseable.
Solution is very simple you need to erase security on Hd
Make a bootable Cd with
Use this program called HDDErase v3.1 go in it
Press Y to Proceed
Press N to go next page
Press Y to Agree
Now you will see list of your diveces listed P0 then P1 then for you parallel and S0 and S1 for sereal
Type you drive press enter
Ask you Do you want to Continue Press Y

On top it will say Security Erase

and also will say it may take from 20 min to few hours and on the bottom dash will be blinkin
Now let it run untill it will be done it took 250gb 2days and 2 nights
after its done go to your HD disk provider lifeguard for western digital
Run Extended test and see that its been unlocked now you can write zeros on the hard drive and put it back to use too bad you wont recover you data...

It will work if you need the cd with that program left me know i can send it to you as iso file
!