Sign in with
Sign up | Sign in
Your question

Corsair H50 - stock fan seems slow at 100% - 570rpm.

Last response: in Components
Share
January 13, 2013 3:49:19 PM

Hello,

I have a first generation Corsair H50 with the stock fan and it says it's a 1700rpm fan, but I can't get it over 570rpm.

BIOS has it maxed at 100% - other case fans at 1500 and even the H50 pump is 1400. Why does the radiator fan seem so slow?

Do I need a faster or more CFM fan? Thinking of doing push/pull as well. (Suggestions? Thinking of dual 4250rpm Scythe Gentle Typhoons in push/pull - any experiences)

Idle temps ok, been afraid to push it with the low fan speed, thinking it might cause irreversible harm to the processor if malfunctioning.


Thanks in advance!

System info if needed:
Intel 3770K i7 at 3.5Ghz (non-OC)
ASUS Sabertooth Z77
32GB Corsair Vengeance
600GB Velociraptor
Corsair HX1000w PSU
EVGA GTS 460
January 14, 2013 9:03:22 AM

Maybe it's full with dust. Have you opened the case?
January 14, 2013 9:57:09 AM

rezervesizeja said:
Maybe it's full with dust. Have you opened the case?



Thanks for the reply rezervesizeja, I wish it were that simple. New Install. No dust yet. -- So at least I am correct to be concerned? That is something.
January 22, 2014 11:33:06 AM

malinst said:
rezervesizeja said:
Maybe it's full with dust. Have you opened the case?



Thanks for the reply rezervesizeja, I wish it were that simple. New Install. No dust yet. -- So at least I am correct to be concerned? That is something.

Does it appear to spin slowly? I.E., do you see it spinning at a very slow speed? First, turn the computer off and spin the fan. If it spins well, the brushes could be bad (assuming it has them). My advice is to buy 2 new fans and run them in push pull. I did away with the Corsair ones. Try two Antec 120mm three speeds. Just leave them on the medium setting all of the time.
!