GTX 670 LAG! Help.

Well my card just arrived today. and ........ Im running wow and man im hitting some BAD lag in diablo 3. its crazy. I dont know whats wrong. Could it be my hardrive as well ? Im using a hardrive that i used when i had the DELL XPS 435mt.

Anyone have a solution? i downloaded all the latest drivers..

PS: Im in Alterac Valley in WoW and im hitting 30 FPS..
28 answers Last reply
More about help
  1. What are your computer specs?
  2. I5 2500k
    ASUS GTX 670 DirectCU II
    Asrock Z77 Extreme 4
    8 GB RAM Ripjaws
  3. What video card did you have before? The 670 uses pcie 3.0 something the I5 2500k does not support
  4. Oh screw me -______________- are u serious ?! I had a XFX 7850
  5. I believe so, if you needed to fully use the pcie 3.0 you need at least an i5 3570k...i may be wrong i am aware that pcie 3.0 and 2.0 are backwards compatible, so i may be wrong on your problem though.
  6. undergroundtech said:
    What video card did you have before? The 670 uses pcie 3.0 something the I5 2500k does not support


    All you need is PCIE 2.0, and the i5 2500k does support it. Diablo was known to have problems with stuttering when using the older Nvidia drivers.

    Download drivers: 304.79 and do a clean install and run Diablo 3 again!
  7. The PCIe 2.0 vs. 3.0 is a non-issue.

    Make sure you did a proper uninstall of EVERYTHING AMD/ATI through the Control Panel Add/Remove Programs.

    Then install the latest 304.79 beta drivers using the clean install option.
  8. 17seconds said:
    The PCIe 2.0 vs. 3.0 is a non-issue.

    Make sure you did a proper uninstall of EVERYTHING AMD/ATI through the Control Panel Add/Remove Programs.

    Then install the latest 304.79 beta drivers using the clean install option.


    I just said that...
  9. I'm sorry underground tech, did you know that a GTX 670 will work even in a PCI-E 1.0 slot as all are backwards compatible. It works great on my aging X58/i7 920 setup.

    @noobnasty, first use driver sweeper to uninstall the old graphics driver and install the latest driver.
  10. Guys stop talking about PCIe 3.0 if you don't understand how tis work.

    1) A single 670gtx won,t show any improvement betwin 2.0 and 3.0 PCIe.
    2) the 670gtx is PCIe 3.0 ready but will work just fine with PCIe 2.0
    3) Nvidia drivers seems to be pretty buggy with the 670gtx series for some reason
    4) His spec should see 100+fps in 1080p in D3 if evferything worked well.
  11. Also, make sure you have the latest patch too, it was just released.

    http://us.battle.net/d3/en/blog/6648349/Patch_103b_Now_Live-7_10_2012
  12. venur said:
    Guys stop talking about PCIe 3.0 if you don't understand how tis work.

    1) A single 670gtx won,t show any improvement betwin 2.0 and 3.0 PCIe.
    2) the 670gtx is PCIe 3.0 ready but will work just fine with PCIe 2.0
    3) Nvidia drivers seems to be pretty buggy with the 670gtx series for some reason
    4) His spec should see 100+fps in 1080p in D3 if evferything worked well.



    I will do some test soon. i will let u know how this goes. the in game FPS for diablo stays 0 on my screen, anything that i can use to show how much FPS im running ?
  13. You can use Fraps to even take screenshots and videos ingame, but do know that it will take off about 5 FPS from whatever GPU you are using.
  14. GG. i just drop 8 FPS in mob fight. Standing still at Arriant Gate got me no 40-45 FPS. I dont know what is wrong. i uninstalled ALL AMD drivers and AMD related stuff already..
  15. Did you use Driver Sweeper to uninstall any bits that are left when uninstalling them the default way? Use that when you are updating the GPU drivers, it could be that bits of a previous driver version is causing the issues.
  16. Yup nomore ATI/AMD stuffs. I just loaded diablo 3 and man man my avg is around 20's FPS in Arriat Gate.

    I really dont know. im about to return this card. Help please guys!
  17. Check out your Nvidia Control Panel settings. Turn off Ambient Occlusion, take a look at some of the other settings and see if there is something turned up too high.

    Hopefully you are now running the 304.79 drivers.
  18. Have already done that matto...

    I did some benchmark in Unigine Heaven and this what it came. For some reason i dont know why my GPU Model is Intel HD 3000. I have a GTX 670.

    http://imgur.com/QII0Q
  19. lol, man you're using your on board graphics built into your 2500k, do you have your monitor connected to teh GPU itself?
  20. In the control panel advanced settings you should be able to change the main display to your 670. Also, do make sure the monitor is connected to the GPU and not the motherboard.
  21. joedjnpc said:
    lol, man you're using your on board graphics built into your 2500k, do you have your monitor connected to teh GPU itself?


    Really, do you think he's going to score 41 fps in Unigine Heaven with Tesselation set to extreme, 8XAA, 16XAF? That score is great!

    If Lucid Virtu is installed it will show Intel HD graphics which is normal. OP can go into Virtu control panel and turn it off and reboot...
  22. RussK1 said:
    Really, do you think he's going to score 41 fps in Unigine Heaven with Tesselation set to extreme, 8XAA, 16XAF? That score is great!

    If Lucid Virtu is installed it will show Intel HD graphics which is normal. OP can go into Virtu control panel and turn it off and reboot...


    Sorry about that, was hasty, didn't look at the bench, thought the graphics showing as "intel hd 3000" would have been enough to identify the problem.
  23. joedjnpc said:
    Sorry about that, was hasty, didn't look at the bench, thought the graphics showing as "intel hd 3000" would have been enough to identify the problem.


    It's cool... with the settings the OP had in Heaven I'd say the 670 is performing as expected considering his other system resources.

    My 6990's with the same settings score 93 FPS give or take. I can run it a hundred times and each time the scores will be different and would have to find the mean.

    Diablo 3 is still fairly new and so is the 670... so I would think would be the reason for his particular "lag".
  24. Yeah but u know i expected the card to run a lot better . Most especially in Diablo 3. Im gonna buy BF3 and we will see how the FPS is gonna play out. Im really disappointed at this right now.
  25. i have bought gigabyte gtx 670 and did complete new installation of windows and installed latest drivers and i am facing the same problems as OP i am confused as well like in Batman Arkham city fps ranging from 30 - 65 and in one scene when first time Joker comes to fight himself the frames dropped to around 10 continuously for around 10 minutes i dont know what Nvidia is doing In MW3 at 1920x1080 i am getting 42FPS constant which should have been much more similarly in NFS RUN FRAPS is showing 30fps constant?????????????? What is happening ? NVIDIA WAKE UP!!!!!!!!!!!!!!
  26. look how horrible my stream looks.. www.twitch.tv/liketoks
  27. Well make sure your RAM timings are set correctly, overclock your 2500k to 4.2GHZ, make sure your GPU is running on BOOST and is the primary display adaptor. Turn off MSXX/AA
  28. How do i turn off MSXX/AA ? And how do i make it run on boost? Sorry im not too familiar with all of this..
Ask a new question

Read More

Graphics Cards Lag World Of Warcraft Graphics