Sign in with
Sign up | Sign in
Your question
Solved

It takes a very long time to get an Internet connection

Last response: in Networking
Share
September 3, 2011 3:44:43 AM

I just built a new machine that uses an ASUS P8P67 R3 Deluxe motherboard, the one with a pair of ethernet ports (one Realtek, the other Intel).

When I boot up the machine, it will get an IP address immediately (as shown by ipconfig), but it can only communicate with other computers on the network. No Internet connection is immediately available. The icon in the system tray shows no Internet access, and checking the status of either ethernet port will show the same thing. Running Windows' network troubleshooting wizard claims that the DNS is not responding. No other wired computer suffers from this problem.

I've already updated the drivers for the ethernet ports to the latest shown on ASUS' site.

Right now, my only option is to sit and wait until the Internet connection restores itself. I suppose it is a minor thing, but it is extremely annoying and I could use a hand figuring this one out.

Thanks!
September 4, 2011 1:38:19 AM

I updated the Realtek driver via Windows Update, and update that it did not offer yesterday. I have also plugged an ethernet cable into both of the ports. These two things did not solve the problem, but the computer seems to gain access to the internet just a bit faster now. Still not great, but there is a bit of an improvement.

Any ideas are still appreciated.
September 4, 2011 7:17:21 PM

Right click on your network connection icon in the lower right and go into Network and Sharing Center. On the right in the middle click on "Local Area connection". Go to Properties, then double click on Internet Protocol Version 4. Under DNS server address manually enter 8.8.8.8 and 8.8.4.4 (Google's public DNS servers).

See if that works, if it does something's up with your ISP's DNS servers.
Do you get the same problem with the Intel NIC card? I have the same motherboard and I think my Realtek NIC is faulty and I'm too lazy to replace this board for a 3rd time.
Related resources
September 4, 2011 10:14:04 PM

Thanks for the idea. The router is already set to use Google's DNS but I tried your method anyhow and it didn't change the current situation. Also, it seems that the Intel port never works. The Realtek one eventually gets a connection.

Using Device Manager I have uninstalled both network devices, including deleting the drivers. Restarting Windows causes the Realtek ones to install themselves again, but it doesn't change the situation.

Running the Troubleshoot Network Problems wizards results in a different issue every time. Sometimes my broadband modem is not connected. Sometimes there is a disconnect between my computer and the modem. Sometimes the DNS is not responding. It is like Windows is just guessing and has no idea what the real problem is.

When I try to ping a server, I get the error "Ping request could not find host [site]. Please check the name and try again." It really looks like an ISP issue, but I don't believe that is the case because my wife's computer is hard wired into the same router, using the same internet connection and this doesn't come up for her. The fact that this new computer immediately gets an intranet connection, but can't communicate with the internet, tells me it isn't a hardware issue either. This computer will eventually connect to the internet, but I honestly have no idea what I am doing to get it to work the few times it ever does.

Right now, my focus is squarely on the drivers. Please tell me if I'm looking in the wrong place.

Best solution

September 6, 2011 10:39:33 AM
Share

It could be a hardware issue causing intermittent connectivity. When it is NOT working do you have any lights on the NIC card? If you haven't already I'd replace the cable connecting your PC with your router. Try plugging it into a different router port just to rule out any hardware issues.

How is your wife's PC configured? DHCP? Static?
How is your PC configured?
What is the IP address your PC is getting?
When you do IP config do ipconfig /all to also show everything and compare that with your wife's working PC.

I'm still thinking it's a DNS issue, that ping response definitely sounds like a DNS issue. Ping an IP address instead of a site's name. Try pinging 74.125.224.51 or 72.30.2.43
September 8, 2011 12:37:11 AM

You were on the right track. The DNS thing really should have been a bigger clue, but I refused to acknowledge it.

I exchanged the board for another P8P67. Same problem, except the Intel was giving me trouble and the Realtek port stopped working. So I connected the PC to the modem, bypassing the router (WNDR3700) and suddenly, instant internet access. I tried another router (WRT54G) and that worked too.

So I did a factory reset on the WNDR3700 and all was well again. I was so fixated on the computer itself because no other machine in my network suffered from this problem!

Thank you for taking the time out to help. Now I can game with this thing and start having fun.
September 15, 2011 2:03:13 PM

Best answer selected by chillpenguin.
!