Sign in with
Sign up | Sign in
Your question
Closed

Sapphire HD Radeon 6870 - No Video

Last response: in Graphics & Displays
Share
July 14, 2012 3:01:28 AM

For some reason my Sapphire Radeon HD 6870 isn't outputing video with my rig. I read issues of a comparability issue between my mobo, cpu, and GPU and I wanted to know if anyone here knew anything about that. It's way too late to return the card so I might just buy a 7850 if I can't get this card to work and then try to sell this card if it's not broken. I'm taking my PC to the shop tomorrow to see if my card is broken or if there's a problem with something like my PSU (it's 600w which should be fine). I tried an old card that doesn't require a power connector and it works. I'm currently using the onboard video to use my computer but would like to game with my GPU.



Here is my system:
Operating System
MS Windows 7 Ultimate 64-bit SP1
CPU
Intel Core i3/i5/i7 @ 3.30GHz 32 °C
Ivy Bridge 22nm Technology
RAM
11.7 GB
Motherboard
ASRock Z77 Extreme4 (CPUSocket) 31 °C
Graphics
Acer G185HV (1366x768@60Hz)
Acer G235H (1920x1080@60Hz)
Intel(R) HD Graphics
Hard Drives
977GB Hitachi Hitachi HDS721010CLA332 (SATA) 32 °C
244GB Seagate ST3250820AS ATA Device (SATA) 35 °C
Optical Drives
ATAPI DVD A DH16AAS ATA Device
ELBY CLONEDRIVE SCSI CdRom Device
Audio
Intel(R) Display Audio

Thanks.

Best solution

July 22, 2012 3:22:34 AM

Same issue - A Sapphire HD 6870 1GB that the motherboard won't detect. In my case it's a Gigabyte Z77X-UD5H with a 3570K installed. Fans on the card fire up but the system just won't see it.
Installed all Intel drivers, re-flashed the BIOS, tried each PCIe slot, you name it. Card works fine on an old X48 board. I'm not entirely sure if I should RMA the motherboard or replace the card at this point. HD4000 works fine (well, for surfing the web) and there are no other hardware issues.


Microsoft Windows 7 Home Premium 64-bit
Intel Core i5-3570K @ 3.40GHz
(RAM) 8.00 GB DDR3 1600
Gigabyte Z77Z-UD5H
240GB Mushkin SSD


bluj162 said:
For some reason my Sapphire Radeon HD 6870 isn't outputing video with my rig. I read issues of a comparability issue between my mobo, cpu, and GPU and I wanted to know if anyone here knew anything about that. It's way too late to return the card so I might just buy a 7850 if I can't get this card to work and then try to sell this card if it's not broken. I'm taking my PC to the shop tomorrow to see if my card is broken or if there's a problem with something like my PSU (it's 600w which should be fine). I tried an old card that doesn't require a power connector and it works. I'm currently using the onboard video to use my computer but would like to game with my GPU.
Share
July 22, 2012 3:28:25 AM

I got an ASUS 7850 2GB and it's working beautifully (after I re-installed the drivers because the ones that came with it were piss poor.)

Score
0
Related resources
July 22, 2012 3:28:42 AM

Best answer selected by bluj162.
Score
0
a c 273 U Graphics card
July 22, 2012 6:55:18 AM

This topic has been closed by Mousemonkey
Score
0
!