HD 5450 showing as standard VGA adapter

After installing my ATI HD 5450,the display resolution got reduced from 1920x1080 to 1400x1050 and the display is of very low quality.The card wont get detected as ATI 5450 but it is showing as standard VGA adapter,i used SIW and CPU-Z to detect the driver,which is getting detected but the name is still shown as standard VGA adapter. I also used the "AMD Driver Autodetect" and it showed the same driver which i downloaded from the AMD site,i.e,12-6_vista_win7_32_dd_ccc,for my 32-bit Windows 7 OS.Now i did try installing all the drivers but after installation is complete,i still cant see the catalyst UI or any exe file of catalyst which i am guessing could be because the drivers didnt get installed at all.Can anyone help me out with this?
2 answers Last reply
More about 5450 showing standard adapter
  1. go to your control pannel > uninstall > express uninstall
    restart
    download newest ATI drivers for your OS
    right click on the file you downloaded >run as administrator > express install
    restart
    should work.

    If it doesn't.
    Unplugmonitor > manually power down computer by holding power button or pulling plug> start up, wait for windows sounds plug in monitor

    I've done the latter in the past and had it work for me in the exact same situation you're describing.
  2. Well,i did both and it didnt work,but then i enabled windows updates,and downloading and installing those updates fixed the problem. Thanks a lot though for taking out the time.
Ask a new question

Read More

Graphics Cards VGA HD Graphics