Sign in with
Sign up | Sign in
Your question

Frequent BSODs with XFX 6770

Last response: in Graphics & Displays
Share
July 14, 2012 4:18:09 AM

Hey.

I've been experiencing recurring BSODs while running video games on this card since purchasing it (The XFX Radeon HD 6770). At the very least they happen once a day (provided I'm in a video game at the time, or watching a youtube video). They only seem to happen in specific games, most notably ones more recently released (games before around the 2008 mark, like Tomb Raider Annerversary, don't seem to have this problem and I can have full gaming sessions without a crash). Games like Skyrim, Left 4 Dead 2 and Just Cause 2 seem to give me frequent crashes. I've attempted to Reseat the card, clean it of dust(which shouldnt be a problem considering it's a month old), install older drivers, uninstall monitoring tools like MSI Afterburner, update my directX drivers, and run videogames without other background applications, but all these attempts haven't seemed to have had any effect whatsoever. It's gotten to the extent that often I can run games like Skyrim for no more than 30 minutes before experiencing a crash.

My computer specs are as follows:
ATI Phenom II X2 555 Black Edition(Unlocked to 4 cores)
1TB Hard Drive
Windows 7 Ultimate 64-Bit
4GB RAM
Gigabyte MA770T-UD3 AM3 Socket Mobo
XFX Radeon HD 6770

This is the minidump generated by the crash. I couldn't see any option for attaching files on this board so I hope hosting it on my dropbox instead isn't an issue. If there's any more details that I need to give, tell me.

Thanks
July 14, 2012 1:43:50 PM

Did you stress test the CPU after you unlocked it & are al your temps OK?
July 14, 2012 2:07:49 PM

Try without unlocked core if it still crash.....

Unstable cores could be the reason..
Related resources
July 14, 2012 3:57:07 PM

I recall running Prime95 for about 48 hours after unlocking the cores, no errors whatsoever. I'm not sure how the CPU could have any part in this as I never had any issues involving BSODs with my previous card(which was the 5770).
July 15, 2012 11:16:25 PM

Apologies for double-posting, but I tried locking the cores again. Received a crash within 20 minutes of playing The Witcher. Temps were within reason, around 60-70 degrees on the card which is perfectly normal.

I'm at straws here, i have no idea whats causing the crashes. Does anyone have an ideas? :/ 
!