Sign in with
Sign up | Sign in
Your question

[Solved] Reboot sets gateway to 0.0.0.0

Last response: in Networking
Share
September 3, 2011 6:55:41 PM

Hi People!

I use windows 7 pro 64, and just in this last month (which makes me think a windows update is responsible) I got a problem where restarting my pc or any bootup causes the internet to break. By that, I mean that all of my devices are recognized and peripherals such as phones & ps3 can use the internet, but my PC has broken functionality.

internet ---> modem --->Wirelessrouter ---> PC (eth/wifi, not working)
-------------------------------------------------> Ps3 (wifi, working)
-------------------------------------------------> All others (wifi, working)

Here is an image, if it helps. In the prompt at left, I have run ipconfig twice. The first time is immediately after a restart. The second time, about halfway down, is after manually reinstalling my realtek ethernet drivers. It does not matter which version I install, only that it is done manually: then the internet works:



REVISION: It appears that every reboot sets my default gateway to 0.0.0.0, which is of course incorrect. How do I stop this from happening?
September 5, 2011 7:24:11 PM

Can anyone provide any tips for this? It's really annoying having to manually reinstall my drivers after *every* restart....plz help!
m
0
l
September 5, 2011 8:32:58 PM

I sympathize with you. This is a "long weekend" and it seems nobody is here. I don't have Windows 7 so I can't be of much help. If it was XP I'd tell the person to un-check the IPv6 in the network properties as a starter. If this works for you, great, and if not, well, more people will return on Tuesday.

I would go into greater detail but whatever you do from me must be able to be put back instantly if it didn't work out.
m
0
l
Related resources
September 9, 2011 7:35:04 AM

tigsounds said:
I sympathize with you. This is a "long weekend" and it seems nobody is here. I don't have Windows 7 so I can't be of much help. If it was XP I'd tell the person to un-check the IPv6 in the network properties as a starter. If this works for you, great, and if not, well, more people will return on Tuesday.

I would go into greater detail but whatever you do from me must be able to be put back instantly if it didn't work out.


Alright, I tried that, but it had no effect.

The only thing I can think of is to revert a months' worth of updates, then reinstall them one at a time until I find the culprit. That's going to be fun :( 
m
0
l
September 9, 2011 2:46:58 PM

Have you tried to do a windows automatic repair when the issue comes up? It may change something to help the settings stick. When you see a "no internet access" error in the system try, right-click it and do a repair. Windows 7 is actually the first Windows that I've seen do this pretty well.

As far as updates causing issues, I worked once for a week to find an issue with a scanning application in our Radiology department. For some reason, some of our computer builds with XP would scan, but not save to the netwok, the "Save" button was greyed out. When I finally found the issue, it was a Windows Media Player patch that caused this. Which really should have absolutely nothing to do with scanning or any network save functions. But there it was. So who knows what one of the patches did for you, but hoping it's not something totally unrelated to the issue.
m
0
l
September 10, 2011 6:39:09 AM

This issue has been solved. I have found that the culprit responsible is Adobe's own "Bonjour" service, which comes with Photoshop, among other things. You must at the least disable "Bonjour's" service through services.msc, or completely delete it from your system (like I did.)
It may give you trouble, saying that certain files cannot be deleted. If this happens then rename the responsible files in your Bonjour folder, which will probably be in C:\Program Files\Bonjour (or in my case, C:\Program Files (x86)\Bonjour). After renaming them, restart your pc and then delete them.

Yayness.
m
0
l
!