Sign in with
Sign up | Sign in
Your question

Can't find my bottleneck

Last response: in Graphics & Displays
Share
July 14, 2012 8:30:02 PM

This is driving me mad, I've been doing everything I can think of for the past few months trying to track down a bottleneck, any suggestions? (2-3 seconds of huge fps drop in certain games like arkham city, GPU usage max of ~ 50%)

i5 2500k OC to 4Ghz with coolermaster hyper212+ cooler
z77 extreme 4 motherboard ( replaced a DH67GDB3 )
Stock OC Asus DirectCU II GTX 670 (non TOP, replaced a GTX 580)
120GB Intel 510 SSD in a 6Gbps port
1 TB Deskstar Sata 2 mechanical drive, 7200 rpm
Corsair TX850 PSU
Venomtoxic case, max fans
2 x 4GB DIMMS of CMZ8GX3M2A1600C9 Corsair Vengeance
Windows 7 Ultimate 64 bit

As mentioned I replaced the GTX 580, thinking that was the issue. Re-occurs with 670 although it's slightly better.
Today I swapped in a z77 for my old motherboard and overclocked to 4.0GHz as I thought the old motherboard might have been the bottleneck or the CPU. Issue still occurs.

My setup for Arkham city -

Steam installed on mechanical drive, I've moved Arkham City to my SSD and tricked steam by putting a symlink to arkham city on the mechanical drive.

Now I think that I should be able to play arkham on highest on 1080p, maybe I'm just overestimating my gaming rig?

More about : find bottleneck

July 14, 2012 8:37:25 PM

I wouldn't say you have over-estimated your rig, it should run really well. Is it just Arkham city that is experiencing this issue? If so, it's likely a problem with the drivers, in which case go and download the latest from nvidia. If it's still acting up, try re-installing the game.
a c 271 U Graphics card
July 14, 2012 8:38:33 PM

Are you sure it's not the Symlink causing the lag?
Related resources
July 14, 2012 8:46:24 PM

Thanks guys,

I'm on the very latest beta drivers from Nvidia (304.79)

I've been using the latest driver for the past month as there was the kepler stuttering issue, which I thought might have affected me. That's been fixed in this new driver so I'm ruling it out.

I'm running a 12 hour burn-in test with prime95 on my OC currently so I'll check back in the morning.

My next step is (another) complete wipe of the system and to install steam and arkham city only on the SSD.

I experience issues in other games, I just really notice it in arkham city. Having said that arkham asylum on the SSD worked fine, I have a feeling it may be due to steam being on the mechanical drive but I don't see the logic as to how that's possible. I have 8 GB ram so I would assume that once I load the game most of it is going to be loaded into RAM.

Another possibility is that games fall over without a paging file? I've disabled pagefile since I have plenty of RAM and don't want to stress out my SSD
a c 271 U Graphics card
July 14, 2012 8:50:50 PM

You could try re-enabling your pagefile but limit it to 4GB and see what happens.
July 15, 2012 10:40:22 AM

No good, just resulted in a hell of a lot of pagefaults at the same time as the stuttering which is bringing me back towards hard drive, it is a pretty huge game. I'm going to try a fresh installation with Arkham City and Steam the only apps on the SDD
July 15, 2012 12:38:01 PM

Fresh installation, same issue :( 

Steam and Arkham City are now on the same drive, out of desperation I turned all graphics to lowest and the issue still occurs.
July 17, 2012 6:19:11 PM

Since reinstalling I have noticed that occasionally my Desktop will freeze for 2-3 seconds. I think I'm getting closer. I don't notice this in Linux, then again I don't have any massively graphical linux apps
July 29, 2012 12:46:36 PM

I've confirmed the same issue with several games now, Batman: Arkham City & Deus Ex Human Revolution. Please help :*(
July 29, 2012 12:59:54 PM

I'm not sure but I have had a problem where my gpu was way too oc and just starts to fall to 5fps and stutter everywhere lol... check to see if its factory overclock is stable.
July 29, 2012 3:47:03 PM

Hi Joe

Can you recommend how to check this out?
July 29, 2012 4:22:36 PM

If you get a program called furmark and run the stability test it should tell you your temps/fps at a stress test level that way you can check if your graphics card is trying to do too much Here is a link

http://www.ozone3d.net/benchmarks/fur/
July 29, 2012 7:50:36 PM

I dropped the clock to 915 in gpu tweak and it seemed to help deus ex but still see issues in other games. I ran furmark at these settings

Burn in - 800x600 -

Core - 967 MhZ
Mem - 3004MhZ (shows 6008 in the gpu tweak)
Load - 76%
FPS = 60
Power - 101% TDP

1920 x 1080 -
core 1032 MHz,
mem 3004 MH\,
load 99%,
FPS 18
Power 100%TDP


Any suggestions on what's going on here? (gpu voltage in gpu tweak was 1175)
!