Sign in with
Sign up | Sign in
Your question

Amd Lever will not go down

Last response: in CPUs
Share
January 17, 2013 3:33:14 AM

Hello, building my first computer now. I am having trouble with the processor. See what had happened was the first time I installed it, the fan did not fit, so I took it off and along came the CPU. Then it got 4 bent pins but I managed to straighten them all and now the processor fits in the socket well enough to drop it in without it wiggling at all. But when when I try to latch it down, there is a small force that is stopping me, and I don't think that's normal. What is the reason for the leaver giving force while the processor is in the socket, and what can I do to make it go into place?

EDIT: The first time I did it I had to apply no force. I just did some research and some people say that resistance is normal. It starts the resistance at about 75 Degrees. Is this normal, and should I apply the force needed to latch it down? The CPU is fit in the socket with all 4 corners there. Thanks for helping me out.

EDIT: This is a AMD processor. I'm seeing way more post about Intel than AMD, just want to make sure you know that. Is this normal for a AMD processor to do this?

More about : amd lever

January 17, 2013 4:43:15 AM

Sorry, I'm looking for an answer ASAP. Bumping thread.
a c 141 à CPUs
January 17, 2013 4:51:19 AM

Just push the lever all the way down. If it goes all the way it should be fine if you apply pressure and it still doesn't move then there is something else wrong.
Related resources
January 17, 2013 2:59:34 PM

rds1220 said:
Just push the lever all the way down. If it goes all the way it should be fine if you apply pressure and it still doesn't move then there is something else wrong.

Thanks for your help. The CPU went in okay. I just had to be sure.
a b à CPUs
January 17, 2013 3:07:59 PM

I had the same problem, I thought I was going to break my motherboard it was resisting so much, just pushed it all the way down despite the resistance and it clicked on. It was fine from there on
a c 141 à CPUs
January 17, 2013 8:18:37 PM

CurtisCoburn said:
Thanks for your help. The CPU went in okay. I just had to be sure.


As long as it went all the way over and the computer turns on it is fine.
!