Sign in with
Sign up | Sign in
Your question

BSOD when using SLI. Seems to be a registry problem

Last response: in Graphics & Displays
Share
July 15, 2012 11:00:43 PM

Alright, I'm running Vista SP2 and recently ran into a problem when trying to run my cards in SLI. I have 8800GTX's, both of which work perfectly well when running alone, regardless of which PCI slot they are in, so I don't think its a hardware problem. Only other possibility is a problem with the SLI bridge, but I find that unlikely.

Anyways, what is happening is that when trying to run my system in SLI I get almost instant BSOD's with the screen saying something about a registry error. Prior to the BSODs I was able to access my desktop in SLI mode, but whenever I tried to play a game it would either crash or have these strange blue colors on the screen (this makes it seem like its hardware related but I don't think that is the case) I'm not sure what changed during all the tinkering I was doing but now it just loads to desktop and BSOD's when using SLI.

What I think the source of the problem might be is that a few days ago I ran driver sweeper and ticked the Nvidia-chipset option to clean, which I've never done before. I'm not exactly sure what that did, or even what Nvidia-chipset is, but if it deleted registry values that were needed then that might be the problem. Does anyone know of a way to potentially fix this? Worst comes to worse I'll reformat but I'd rather not as its a pain. Here is my crash file from windbg if that helps. Also, I don't have any system restore points early enough to fix it, and using the restore feature on driver sweeper didn't help (although I didn't even see files related to the chipset in the backup files):




Microsoft (R) Windows Debugger Version 6.9.0003.113 X86
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\Minidump\Mini071512-03.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*DownstreamStore*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows 7 Kernel Version 6002 (Service Pack 2) MP (4 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 6002.18484.x86fre.vistasp2_gdr.110617-0336
Kernel base = 0xe321e000 PsLoadedModuleList = 0xe3335c70
Debug session time: Sun Jul 15 13:11:18.715 2012 (GMT-4)
System Uptime: 0 days 0:01:29.808
Loading Kernel Symbols
........................................................................................................................................................................
Loading User Symbols
Loading unloaded module list
......
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 51, {1, c8a245c8, 248f000, 368}

Probably caused by : ntkrpamp.exe ( nt!HvpSetRangeProtection+40 )

Followup: MachineOwner
---------

0: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

REGISTRY_ERROR (51)
Something has gone badly wrong with the registry. If a kernel debugger
is available, get a stack trace. It can also indicate that the registry got
an I/O error while trying to read one of its files, so it can be caused by
hardware problems or filesystem corruption.
It may occur due to a failure in a refresh operation, which is used only
in by the security system, and then only when resource limits are encountered.
Arguments:
Arg1: 00000001, (reserved)
Arg2: c8a245c8, (reserved)
Arg3: 0248f000, depends on where Windows bugchecked, may be pointer to hive
Arg4: 00000368, depends on where Windows bugchecked, may be return code of
HvCheckHive if the hive is corrupt.

Debugging Details:
------------------


CUSTOMER_CRASH_COUNT: 3

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

BUGCHECK_STR: 0x51

PROCESS_NAME: services.exe

CURRENT_IRQL: 0

LAST_CONTROL_TRANSFER: from e33fff72 to e32ebb3f

STACK_TEXT:
d31da94c e33fff72 00000051 00000001 c8a245c8 nt!KeBugCheckEx+0x1e
d31da994 e33fe88e 0248f000 712de000 00000004 nt!HvpSetRangeProtection+0x40
d31da9c8 e33fd79d c8a245c8 00036b72 7373616c nt!HvMarkDirty+0x43b
d31da9f0 e338eb96 00036b76 00000000 d5bb6c24 nt!HvMarkCellDirty+0x22b
d31daa40 e338e9e4 00000000 01bb6c24 c8a245c8 nt!CmpMarkKeyValuesDirty+0x10f
d31daa58 e338e3d4 c8a245c8 017e7c20 d994cea4 nt!CmpFreeKeyValues+0x15
d31daac4 e338e1ab c8a245c8 d994cea4 c8a245c8 nt!CmpSyncKeyValues+0x3d
d31dab10 e338dfaa cf033000 c8a245c8 c8a245c8 nt!CmpCopySyncTree2+0x1e9
d31dab34 e338df00 c8a245c8 000001d0 c8a245c8 nt!CmpCopySyncTree+0x3d
d31daca4 e338db6e 0001000a d31dad48 e338dafd nt!CmpSaveBootControlSet+0x2ae
d31dacc0 e3268c7a 0000000c d31dad58 e3266f45 nt!NtInitializeRegistry+0x71
d31dacc0 e3266f45 0000000c d31dad58 e3266f45 nt!KiFastCallEntry+0x12a
d31dad3c e338db22 0000000c 0009fba8 e338dafd nt!ZwInitializeRegistry+0x11
d31dad58 e3268c7a 0000000c 0009fbe4 77da5ca4 nt!NtInitializeRegistry+0x25
d31dad58 77da5ca4 0000000c 0009fbe4 77da5ca4 nt!KiFastCallEntry+0x12a
WARNING: Frame IP not in any known module. Following frames may be wrong.
0009fbe4 00000000 00000000 00000000 00000000 0x77da5ca4


STACK_COMMAND: kb

FOLLOWUP_IP:
nt!HvpSetRangeProtection+40
e33fff72 cc int 3

SYMBOL_STACK_INDEX: 1

SYMBOL_NAME: nt!HvpSetRangeProtection+40

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: nt

IMAGE_NAME: ntkrpamp.exe

DEBUG_FLR_IMAGE_TIMESTAMP: 4dfb5603

FAILURE_BUCKET_ID: 0x51_nt!HvpSetRangeProtection+40

BUCKET_ID: 0x51_nt!HvpSetRangeProtection+40

Followup: MachineOwner
---------

a b U Graphics card
July 15, 2012 11:36:17 PM

It could be your SLI bridge, you would be surprised that when you have issues with SLI, the bridge is often one of the main culprits. I would suggest using driver sweeper to do a clean uninstallation of your current driver, then reboot, then install the latest driver. Also try rotating the SLI bridge, sometimes it acts funny, but then you rotate it, it works, that is how my SLI bridge works, lol
m
0
l
July 15, 2012 11:52:17 PM

I've tried a clean uninstall and reinstall of drivers and it hasn't helped. I've also tried rotating the bridge (even though im pretty sure its symmetrical) and that didn't help either
m
0
l
Related resources
a b U Graphics card
July 15, 2012 11:53:57 PM

If you can, try another SLI bridge, if all else fails, I would back up your important data and reinstall Windows.
m
0
l
July 16, 2012 12:47:30 AM

Yah I'm going to try another bridge when I can get my hands on one. Does anyone know what Nvidia - Chipset is in driver sweeper? And if so, is it a driver or w/e that I could potentially reinstall?
m
0
l
July 16, 2012 10:50:52 PM

Bump. Anyone any other ideas?
m
0
l
July 18, 2012 11:38:20 AM

Start with trying to run System Restore.

The stack trace indicates the crash is occurring within the NT Kernel & System process, and does not contain any references to other modules like nVidia's drivers.
m
0
l
!