Sign in with
Sign up | Sign in
Your question
Closed

Weirdest problem with Nvidia Graphics card or DirectX (no idea which)

Last response: in Graphics & Displays
Share
July 16, 2012 1:04:51 AM

I'm sorry if the title is a bit confusing, but this problem is confusing in itself, so here whats happened:

I have a laptop with a Nvidia Geforce 9500M GS and a couple days ago, after a day with absolutely no problems at all, I launched Flight Simulator to get a weird error completely out of the blue about me not having a compatible graphics card (What? but I had just played the damn game the day before :pfff:  ). After many tries I just resigned and tried to play Wings of Prey (what can I say. I had a flight itch) only to be greeted with a message about a "shader model not being supported". I have more than 20 hours logged on that game, so needles to say that my computer can (could) run it. To make the story short, after that I tried to run every game I had installed on my computer and the only games I could run (which were Gish and SpaceChem) were OpenGL or flash based. Every other game would either tell that I didn't have a supported GPU or that there was a "DX compatible graphic card was required". Before I forget, my GPU was updated with the last drivers like a week ago, and I had been playing since then with no problems. I also didn't install any other drivers for any other hardware.

Outside videogames, it's as if nothing had happened: everything else worked fine; under the device manager there was no error messages and my GPU was displayed correctly. Other GPU intensive software (Solidworks, Photoshop, 3Dmax, etc) work fine...

My only suspicions:
1- The day before my laptop went on a trip, but it goes on the same trip pretty much every weekend and it's always safely accommodated in my car trunk, so I'm only mentioning it to cover all my bases.

2- Just before all this start happening I had installed e very old game (from 1999) that had lots of trouble running on new machines, so I figured trying to install the DX version that came with it would help, but when I tried it just told me I had a more recent version and nothing happened (or so I thought), but seeing as many of the error I get mention DX, I imagine it may have some correlation.

What I tried so far:
1- Reinstalling the drivers, installing older drivers, uninstalled the drivers and tried to see if anything would run with the default Windows drivers, nothing worked.

2- Tried to reinstall DX, but it tells me the version I have is up to date so it won't do anything. Tried to install a DX from the most recent game I had, and it seemed to bee installing something, but nothing worked.

3- Run my antivirus to see if a malware could be causing this issue, but found nothing (not surprisingly, since I'm very careful with that).

4- Tried to slap and beat multiple times my laptop in hopes that it would eventually solve anything. :fou: 

5- Apologized to my laptop for the treatment mentioned previously :ange: 

Nothing worked so far, and I'm getting a bit desperate. I really wanted to avoid reinstalling Windows, since it's obliviously a pain in the arse having to reinstall everything back. So, here I am, expecting an epiphany from anyone that might be reading this lengthy wall of text.
a b U Graphics card
July 16, 2012 1:32:43 AM

Try completely uninstalling the drivers and DirectX with Driver Sweeper.
July 16, 2012 11:33:24 AM

fb39ca4 said:
Try completely uninstalling the drivers and DirectX with Driver Sweeper.


I already did that, but with Driver Cleaner. I suppose I can try that again with Driver Sweeper that I don't think it'll make much difference.

As for uninstalling DX, I searched on how to do that but the only methods I found don't work with Windows 7 x64. Does Driver Sweeper also uninstall DX?
Related resources
a c 91 U Graphics card
a b Î Nvidia
July 16, 2012 11:56:43 AM

that 1999 game, did you uninstall it and all the software that loaded with it ? and from bouncing around in your trunk..... possible cabling problem. could have slightly worked loose from somewhere.
July 16, 2012 7:48:52 PM

Ok, I think I can safely say that I'm pretty sure that this is a DX problem.

After this start happening I've noticed I could run any media file on Windows Media Player. They would either run for a couple seconds or not run at all before giving a codec error. I just disregarded this and used VLC instead.

Now I started to wonder if WMP used DirectX and search in Google, and came to the conclusion that yes, WMP does indeed use DX while I couldn't find any information about VLC using DX.

So now the question boils down to: How can I uninstall DX from Windows 7?
July 16, 2012 8:24:39 PM

OMG! You can close this thread now. I solved the problem.
I just inserted the cd of the old game, and started its DX dialog only to find an option to enable D3D (an option nonexistent in the modern version of DX).
Now, why was D3D disabled in the first place? I might never find out...
a c 271 U Graphics card
a c 168 Î Nvidia
July 16, 2012 8:28:45 PM

This topic has been closed by Mousemonkey
!