Sign in with
Sign up | Sign in
Your question

Bug in Hot Keys for Input Languages

Last response: in Windows XP
Share
Anonymous
July 19, 2005 11:50:30 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Hi,

There's a very annoying bug when configuring Hot Keys for input
languages. Go to: Control Panel > Regional and Language Settings >
Languages > Details... From that dialog, select whatever language and
click on the "Key Settings..." button. Assign some hot key. Now delete
this language. If you now try to assign the SAME hot key to a new
language, you can't, even though the previous language is deleted
forever. Windows displays the following error: "Failed to change key
sequence. Please check if the same key sequence is used for another
item."

Does someone know where in the registry are stored Hot Keys for input
languages? I suppose I have to delete the registry entries manually.

Thanks in advance for any information!

P.S. Reboot doesn't solve this problem.
Anonymous
July 20, 2005 9:01:07 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

OK. I guess like Napoleon said, "If you want a thing done well, do it
yourself." So I took a snapshot of the registry before configuring a
hot key, and another snapshot after assigning the hot key. And then
using a program I compared the too. I discovered that (on my XP box at
least) hot keys are stored at:
HKEY_USERS\S-1-5-21-1659004503-1844237615-725345543-1003\Control
Panel\Input Method\Hot Keys

Here's how I solved my problem, in case someone's interested:
1/ Open Registry and go to the key I mentionned above.
2/ Right-click "Hot Keys" and select "Export". Save the registry file
somewhere. This will be your backup in case something goes wrong.
3/ Delete every subkey under "Hot Keys".
4/ Restart your computer.
5/ Reassign the hot keys in Control Panel as you like.

I still maintain this is a bug, or at least, a bad design. When you
delete a language, Windows should logically delete its hot key
configuration as well.
July 20, 2005 3:51:57 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

In news:1121859297.503601.69140@g43g2000cwa.googlegroups.com,
pepsi_cola40@hotmail.com <pepsi_cola40@hotmail.com> had this to say:

My reply is at the bottom of your sent message:

> OK. I guess like Napoleon said, "If you want a thing done well, do it
> yourself." So I took a snapshot of the registry before configuring a
> hot key, and another snapshot after assigning the hot key. And then
> using a program I compared the too. I discovered that (on my XP box at
> least) hot keys are stored at:
> HKEY_USERS\S-1-5-21-1659004503-1844237615-725345543-1003\Control
> Panel\Input Method\Hot Keys
>
> Here's how I solved my problem, in case someone's interested:
> 1/ Open Registry and go to the key I mentionned above.
> 2/ Right-click "Hot Keys" and select "Export". Save the registry file
> somewhere. This will be your backup in case something goes wrong.
> 3/ Delete every subkey under "Hot Keys".
> 4/ Restart your computer.
> 5/ Reassign the hot keys in Control Panel as you like.
>
> I still maintain this is a bug, or at least, a bad design. When you
> delete a language, Windows should logically delete its hot key
> configuration as well.


While you're at it:

Report:
http://support.microsoft.com/gp/contactbug

This group is not always being monitored by anyone inside of Microsoft
itself. It's best to report bugs directly through the bug reporting page
(calling the number.)

Galen
--

"But there are always some lunatics about. It would be a dull world
without them."

Sherlock Holmes
!