Sign in with
Sign up | Sign in
Your question
Closed

Frame skipping in games. Tried many things.

Last response: in Graphics & Displays
Share
July 16, 2012 5:45:10 AM

Please read my entire post, and not the first two sentences before you instantly determine the solution is to turn on vsync or update my drivers.

First off, my specs.

Mobo: P8Z77-V LX
CPU: I5-2500k
Ram: 4 sticks of DDR3 PC3-15000 1866MHz, equaling up to 16G
SSD: Intel 520 series 120GB
GPU: 570 GTX
PSU: Thermaltake tough power grand. 850W 80 plus gold. The 12v rail can output 71 amps.
OS: Windows 7 Home Premium 64 bit

Now, lets clear a few things here. This computer was HAND BUILT BY ME, so the computer was COMPLETELY clean when I started it up. The first hours on my computer were spent UPDATING DRIVERS, which include but are not limited to my GPU drivers, my chipset drivers, and other important stuff.

Ok, let me explain my problem now in depth. My problem is that my frames seem to be dropping, or "skipping", as the title says. I have had fraps running when this happens, and fraps is CONSTANTLY REPORTING a stable fps of 57-60 fps. This is represented in the smooth motions of whatever may be happening at the moment, however some of the frames just seem to disappear, therefore causing the scene to appear rough and jittery.

Let me give you a more visual example. I was playing this game called Warhammer 40,000: Winter Assault. It is an old RTS, and it goes WAY beyond saying that my computer MORE than meets the recommended specifications of this game. It seems that whenever there are a lot of soldiers on the field fighting, the frames will start skipping. THIS IS NOT TO BE CONFUSED WITH FRAME RATE LOSS!

The frames are at a constant 60 fps, however the soldiers themselves look like they are mini-warping, and not moving smoothly. This mini-warping is the frame skipping in action. Even the camera suffers from this mysterious phenomenon, as you will see the camera movement become "jittery"

The severity of this mysterious glitch varies between games. In Skyrim, I experienced it only in a handful of INSTANCED areas, or in other words, places that I had to open a door and load into a new area. This happens to me very frequently (almost constantly) in Deus Ex: Human Revolution, and Dead Island.

Temps are not an issue I can guarantee you that. My cpu idles at 29-32c, and goes to about 40-44c under load. My gpu idles at 30-34c, and goes to 60-65c under load.

I have tried fiddling with the settings in game and with the NVIDIA control panel, settings which include but are not limited to Vsync, anisotropic filtering, FXAA, and more. I've tried many "fixes" proposed by many users in other forums suffering from the same problem, but nothing works.

Ask your questions.
a b U Graphics card
July 16, 2012 5:54:21 AM

u should use new nvidia driver i suggest use 301.42 driver version not beta which is not fully made it plus check the temp my fx 8150 temp is 35 to 38 when idle mode and when i playing ghost recon future soldier temp increases upto 57 maximum i suggest i u run out of thermal paste on cpu change it 64 is hell for cpu + update the bios of mobo i suggest use 8 gb stick ram because now games not fully optimized to use full ram aand if wont to upgrade to windows 7 64 bitt for full support of 16gb ram 32 only support 3.46 gb usable only go upgrade to 64 bit os
Score
0
a c 203 U Graphics card
July 16, 2012 6:22:44 AM

one thing make sure that your running xmp profile under the dram profile. check that you have your bios sata set to achi and not raid or ide. and the ssd on the right intel sata port. make sure the sata port non intel one are turned off. make sure the intel network software is uninstlled and just the driver is used. on online games and download the intel securoty network software slow your download. online games need good connection to send the video and game data to your pc. if it lagging your fast video card may be running out of data to refresh the screen with. you may also want to go into the asus bios and turn off your c state power management. with light loads and web surfing intel c staes will slow the cpu way down you can see this with open hardware monitor or cpu-z. with them off the cpu will always be running at it max speed. (know the cpu/gpu wont be bottlenecking.) did you in the updates download directx for users. some games need version 9... some run better under version 10. also make sure your running all the game patches. also in nvidia control software make sure your telling it to use all the power of the gpu..turn off energy settings and use one monitor. i would also run the unreal engin test on your pc and see if there error is under dir9 or 10. if your using an over clock card try using msi afterburner and clock the card back to stock.
Score
0
Related resources
July 16, 2012 7:49:39 PM

smorizio said:
one thing make sure that your running xmp profile under the dram profile. check that you have your bios sata set to achi and not raid or ide. and the ssd on the right intel sata port. make sure the sata port non intel one are turned off. make sure the intel network software is uninstlled and just the driver is used. on online games and download the intel securoty network software slow your download. online games need good connection to send the video and game data to your pc. if it lagging your fast video card may be running out of data to refresh the screen with. you may also want to go into the asus bios and turn off your c state power management. with light loads and web surfing intel c staes will slow the cpu way down you can see this with open hardware monitor or cpu-z. with them off the cpu will always be running at it max speed. (know the cpu/gpu wont be bottlenecking.) did you in the updates download directx for users. some games need version 9... some run better under version 10. also make sure your running all the game patches. also in nvidia control software make sure your telling it to use all the power of the gpu..turn off energy settings and use one monitor. i would also run the unreal engin test on your pc and see if there error is under dir9 or 10. if your using an over clock card try using msi afterburner and clock the card back to stock.




I am running my ssd in achi mode and it is plugged into the right sata port. My profile is XMP mode. This problem is NOT occurring in online games, as I haven't even played any of these games online, this is all occurring offline.

I did download directx, it was one of the first things I did when I started my computer for the first time.

Score
0
a c 272 U Graphics card
July 16, 2012 9:28:45 PM

This topic has been closed by Mousemonkey
Score
0
!