Sign in with
Sign up | Sign in
Your question

USB 3.0 problems, please help

Last response: in Components
Share
January 19, 2013 7:09:25 AM

Built a PC with a Gigabyte Z77X-D3H mobo, 8Gb Corsair RAM, i5 3470, in a BitFenix Colossus case. Windows 7 64bit.

I have installed the latest USB 3 drivers but at best they run at USB 2 speeds and on occasion with large files copying has failed.

Also PC will not boot if anything is in a USB 3 port, I have disabled boot from USB in Bios.

Any help would be much appreciated. Cheers

More about : usb problems

January 19, 2013 9:10:30 AM

first
go to bios
then load it default
then open your case
]and check the version of ur mobo
i mean rev
u will find rev. 1.0
or rev 1.1
January 19, 2013 10:40:00 AM

Thanks ok so I loaded default settings in Bios (very noob of me not to have done that already) and the PC booted with the stick plugged in.

The mobo is revision 1.1

I tried copying the same hd video over which took 4:00 mins in USB 2, in the USB 3 port it took 3:10 and the first half was done in 1 min so it dramatically slowed down as it copied.
Related resources
January 19, 2013 10:49:28 AM

Tried the same file to the stick from my sata3 ssd and it took the same time.

I then copied from the stick back to the ssd and it took 1:30 remaining at a steady 74-75 mbps. I t's just the write speed then I assume that starts high and quickly falls to around 40 mbps.
January 19, 2013 11:46:15 AM

Assuming, that it is a usb3.0 stick, the write speed is the problem. Only a few of the sticks can keep up with the 3.0 speed for larger files.
January 19, 2013 11:58:42 AM

If it's a cheap usb 3.0 drive the write speeds will be slow, the more expensive drives can achieve much better speeds.
As the saying going, you get what you pay for.

Try another usb 3.0 drive if its possible.
!