Sign in with
Sign up | Sign in
Your question

New Build - Won't boot into BIOS - Red light On

Last response: in Systems
Share
September 6, 2012 5:21:59 PM

Hi guys,

I just finished my new build today. This is the configuration:

MoBo: ASUS P8Z68-M Pro Micro ATX Motherboard - specification
CPU: Core i7 3770K Quad Core (3.5GHz (Turbo Boost), 8MB L3, 650MHz GPU, LGA1155) BOX, unlocked x
RAM: Corsair Vengeance CMZ16GX3M2A1600C10 2 x 8GB DDR3 1600 - DDR3 1600 (PC3 12800); Timing 10-10-10-27; Cas Latency 10; Voltage 1.5V
PSU: 700W Fortron AURUM, 80 Plus GOLD, Active PFC, 120mm

The problem is that it won't boot :pt1cable: 
As soon as I power on the PC it runs for 20-30 seconds, the DRAM Red Light is constantly on, then the system reboots and still the same thing - red light constantly on - no video output, no BIOS, no keyboard lights, no beeps :( 

I read multiple troubleshoot guides and did everything suggested out there, but still no luck.

Here are the things I've tried out:

- Removed all the PCIe cards, Video card and SSD. It's just the MoBo, the CPU, the RAM and the PSU...with my Monitor and keyboard plugged in ...
- I'm sure that the power cables are plugged into the MoBo (both the 24-pin and the 8-pin cable for the CPU)
- I've Ensured that the RAM sticks fit perfectly into the slots
- I tried with a single stick of RAM. Moved it in each and every slot B1, B2, A1, A2(I know that the blue slots are the default ones) - no luck .... as soon as I start the system the fans start spinning, but the red LED lights on and nothing happens...I can't even get to the BIOS
- The CPU Fan is plugged into the MoBo and is spinning
- I've Re-seated the CPU 2 times - no effect. The CPU Fan is on place, seems to be mounted on MoBo as expected
- Removed the MoBo from the Case and run it outside on a cardboard - still the same thing
- Tried the MemOK button: the system seem to do the tests - it reboots several times with each time the red LED blinking at a different speed...finally the light agains turns constantly on and nothing happens
- Cleared the CMOS RAM using the Jumper on the MoBo (moved the jumper to the other 2 pins, left if for 30 secs and then put it back to it's default position)
- Removed the CMOS battery for an hour and then put it back - nothing changes


Also I don't hear any beeps, but my case is missing a system speaker and I'm not sure if the ASUS P8Z68-M Pro MoBo has an on-board speaker either

It's either the RAM or the MoBo I guess... Could it be a CPU fault..I don't see any CPU LED on the MoBo.
I think that the MoBo should be compatible with this type of RAM...or am I wrong?

I'm thinking about returning the MoBo right now...
Any help is much appreciated!
September 6, 2012 5:39:53 PM

What is your BIOS revision? That cpu is supported after Rev 3702.
-Bruce
September 6, 2012 6:04:59 PM

how can I find out my BIOS version without being able to boot and get to BIOS? (maybe a dumb question :??:  )

September 6, 2012 7:01:50 PM

ok on the mobo it is written Rev 1.01
!