Sign in with
Sign up | Sign in
Your question

I need help!I got a I

Last response: in Graphics & Displays
Share
July 19, 2012 9:19:40 PM

got a new graphics card and now my monitor wont turn on. its saying Power Save Mode and than shuts off. I just got the Rqdeon 6670

More about : question

a b U Graphics card
a b C Monitor
July 19, 2012 9:33:30 PM

Check in BIOS to make sure that discrete or PCI-E video is set as primary video output. Make sure the video cable from monitor is connected to the new video card, not the onboard video. If that doesn't work, try re-seating the video card.

m
0
l
a b U Graphics card
July 19, 2012 9:36:25 PM

or if all that doesnt work try resetting your cmos
m
0
l
Related resources
a b U Graphics card
a b C Monitor
July 19, 2012 10:03:31 PM

Also check your PSU is up to it and someone in this forum didn't tell you it will be fine on a 250W PSU like some people do.
m
0
l
a c 198 U Graphics card
a b C Monitor
July 19, 2012 10:43:28 PM

Hook up the monitor to the onboard video and go into your BIOS, then change the settings to PCI-E rather than onboard.
m
0
l
July 20, 2012 12:16:12 AM

thanks guys, but none of this works ):
m
0
l
July 20, 2012 12:33:16 AM

is it possible to test this card in another computer?
m
0
l
July 20, 2012 1:27:09 AM

flank21 said:
is it possible to test this card in another computer?

no any other suggestions?
m
0
l
a b U Graphics card
July 20, 2012 1:36:29 AM

Do you have a link to the card you bought? Does it need power?
m
0
l
a b U Graphics card
July 20, 2012 1:36:42 AM

And what's your PSU?
m
0
l
July 20, 2012 2:02:25 AM

Thats what I'm trying to find. Is there a way I can find it?
m
0
l
a b U Graphics card
July 20, 2012 2:03:07 AM

What's the make/model of your computer?
m
0
l
July 20, 2012 2:04:54 AM

im not sure, Windows Vista Home Premium maybe? Its a dell. Sorry, not very computer smart.
m
0
l
a b U Graphics card
July 20, 2012 2:07:06 AM

It's a Dell ________ is what we're looking for. There should be a service tag on the back that would say the model.

Like it might be a "Dell Inspiron 620" or something.
m
0
l
July 20, 2012 2:08:21 AM

Oh! Dell Inspriron 531
m
0
l
a b U Graphics card
July 20, 2012 2:09:42 AM

Do you have a link to the graphics card you got?
m
0
l
July 20, 2012 2:11:51 AM

I got it at Best Buy, I just returned the other one because it had a factory mistake. They tested it before it came to my house so it should be good
m
0
l
a b U Graphics card
July 20, 2012 2:12:57 AM

can you find it on their website and post the link?
m
0
l
a b U Graphics card
July 20, 2012 2:23:17 AM

I know what the 6670 is, I was wondering which model you got (who makes it)...AMD doesn't make cards, third parties like XFX, MSI, Sapphire, etc do.
m
0
l
July 20, 2012 2:28:40 AM

otis606, if best buy tested the card to verify it is functional before you bought it and it doesn't work in your computer then you may have a faulty/dead pcie bus or your power supply might not be enough to support the 6670.
m
0
l
July 20, 2012 2:30:39 AM

I think it is my PSU because I had a different graphics card before this one and I can still use my in-computer graphics card
m
0
l
a b U Graphics card
July 20, 2012 2:33:32 AM

Odd though - the XFX 6670 that best buy carries doesn't require an external power connector and that PC supposedly has a 300W power supply.

What graphics card did you have before?
m
0
l
July 20, 2012 2:36:17 AM

geforce gt 610
m
0
l
a c 198 U Graphics card
a b C Monitor
July 20, 2012 2:37:26 AM

Quote:
I think it is my PSU because I had a different graphics card before this one and I can still use my in-computer graphics card


That's what I was asking.

If the graphics on the motherboard still work, then you have to go into the BIOS and change some settings around so the computer knows to prioritize the graphics cards.

When the computer starts, you hit whatever button takes you to the setup. Then you have to change the setup.
m
0
l
July 20, 2012 2:41:36 AM

It does know its there because when I start it up with my normal in cou graphics card it tells me to plug in the cable to the graphics card. I also have a VGA to DVI adapter than a VGA to VGA cable to my monitor
m
0
l
a c 198 U Graphics card
a b C Monitor
July 20, 2012 2:49:12 AM

You could just use the VGA port on the card. Try that out. I still believe you need to go in the BIOS, but I dont think you know how.
m
0
l
July 20, 2012 2:51:07 AM

There is no VGA port on the card
m
0
l
July 20, 2012 4:12:32 AM

The second one and no.
m
0
l
July 20, 2012 4:25:18 AM

Wido . I'll post if it works or not.
m
0
l
July 20, 2012 4:44:14 AM

Still not working.
m
0
l
a c 198 U Graphics card
a b C Monitor
July 20, 2012 5:20:35 AM

Did you switch the setting to use the GPU as the primary? I dont know where it is otherwise Id tell you
m
0
l
!