Sign in with
Sign up | Sign in
Your question

No drivers from mobo cd for hard drive

Last response: in Systems
Share
September 7, 2012 9:06:01 AM

Hi. thanks for looking at my problem! this is the first computer ive built. so far its been easy. but ive been trying to figure this out for hours now. i set up the bios accordingly, then i go to install win7, new hdd so i load drivers from the motherboard cd for the hard drive. but then it says no drivers were found! so i go back to the bios thinking i did something wrong. anyways, long store short, i tried all combinations of hdd setups save raid. (im not planning on using a raid config.) and im still getting the same issues.

i have a ga-970a-ud3 motherboard. a seagate barracuda ST3750525AS. thanks for the help!
a c 106 B Homebuilt system
September 7, 2012 9:09:05 AM

Hard Drives do not have drivers. They have firmware that is hard-coded right into the drive, you cant change it.

SSD's can have their firmware updated though.
m
0
l
September 7, 2012 9:13:01 AM

ok how bout this, bios recognizes the hard drive, but when i go to install 7, the hard drive is no where to be found. it says in my mobo manual that i need to install the hard drive using the motherboards install disk in order to create a partition. (im assuming that how it works.)

"where do you want to install windows"? there is no parition. load driver. d:gigabyte>bootdrv>SBxxxw7>ahci>win7x64 = "no device drivers were found. make sure that the installation media contains the correct drivers, then click ok." thats what the gigabyte manual is saying to do as far as installing the hard drive. so thats what im dealing with
m
0
l
Related resources
a c 106 B Homebuilt system
September 7, 2012 9:40:57 AM

If the BIOS recognizes the drive is there, then so should the Windows install OS.

Any drivers you get off the motherboard CD (unless its a new BIOS or firmware) wont take effect without an OS. A driver is essentially a program that tells an OS how to use a certain component. With no OS its useless.

There is no partition on the drive because it is unformatted. You have to format (or initialize) the drive before you can do anything to it. You should be given the option to do this inside the Windows install.
http://pcsupport.about.com/od/operatingsystems/ss/windo...
m
0
l
September 7, 2012 9:51:42 AM

there is no hard drive to format. when i click the advanced options or whatever it is, everything is grayed out. on the screen where it says, refresh, load drive, and drive options(advanced) there is a exclamation on the bottom saying. no drivers were found, click load driver to provide a mass storage driver for installation. but when i click that it says nothing was found.
m
0
l
a b B Homebuilt system
a b \ Driver
September 7, 2012 10:04:47 AM

Switch the SATA mode to AHCI in BIOS and download the AHCI driver here:
http://www.gigabyte.us/products/product-page.aspx?pid=3... Use the AHCI, not the RAID driver if you don't need raid: "AMD SATA AHCI Driver (Preinstall driver, press F6 during Windows* setup to read from floppy)" The comment says how it works. Download the exe file to another computer and start it. The unpacked files can be copied to a USB stick instead of a floppy. The most difficult thing though is to press F6 when the message shows in the setup. You have about 1 second for that. :) 
m
0
l
September 7, 2012 10:07:28 AM

its all good, thanks for trying!
m
0
l
September 7, 2012 10:11:19 AM

i have the manufacturers cd tho. the one that came with the mobo, or since its not working im assuming that doesn't matter lol.

also, when would i perform f6? do i not need an installed os to do this?
m
0
l
September 7, 2012 10:37:34 AM

i unpacked the folders, plugged it into usb, browsed thru the drive to get to the driver and its still the same thing. no drivers found.
m
0
l
September 7, 2012 9:50:13 PM

just to update. i finally figured it out. i know this topic is quite redundant. i restarted the win 7 set up, at the language selection, i pressed shift+f10 to bring up the command prompt, selected my hard drive from the list disk, cleaned it, and activated it. and lastly restarted and was able to install win7 without any issues. thank you to everyone who took the time to research and respond to my issue!
m
0
l
!