Sign in with
Sign up | Sign in
Your question

Sapphire Radeon HD 7850 not detected

Last response: in Graphics & Displays
Share
July 20, 2012 1:09:49 AM

I recently purchased a Sapphire Radeon HD 7850 to use in my computer build. However, the computer does not detect the card. It does not show up under device manager, and the AMD Catalyst program can't install the drivers because it cannot detect the card. The card is powering up, the fans are running smoothly, and the LED turns on. Here is a list of the other components in the build, all of which have been checked to make sure they are compatible.

Motherboard: Asus P8 Z68-V/Gen3
CPU: Intel i5-2500k @3.3 GHz
Power Supply: Antec HCG-750
RAM: 2x4GB Patriot G2 DDR3
HDD: Seagate 1TB

I've searched online, but can't seem to find a solution to the problem. Any help would be greatly appreciated. Thank you for your time.
July 20, 2012 1:18:21 AM

have you checked the bios to see if the card is sensed in the bios?(and be sure to have the 6 pin connection to the card)
m
0
l
July 20, 2012 2:14:33 AM

dudewitbow said:
have you checked the bios to see if the card is sensed in the bios?(and be sure to have the 6 pin connection to the card)



I have the the 6 pin connected, as I said the card is receiving power. I have checked the Bios, but I didn't see an option that would indicate whether or not it has been detected.
m
0
l
July 20, 2012 2:53:18 AM

one of the options should say that there should be a gpu inserted somewhere. I cant say exactly where because each bios between each company is different.
m
0
l
Related resources
!