Sign in with
Sign up | Sign in
Your question
Closed

The sims 3 Low fps on Nvidia Gtx560 AMD Fx6100

Last response: in Graphics & Displays
Share
July 20, 2012 1:55:10 AM

Hi, i get low framerates(20-40) on The sims 3 since I changed my cpu, I used to have 70-90 fps with a double core and 30 when scrolling. Now I changed my cpu to a Fx 6100 AMD, the point is, i've moved from 2 cores to 6 cores and my fps decreased a lot to a non playable level.

My specs are:
ASROCK n68-s3 FX
8gb RAM
GTX 560 Geforce 1gb
AMD Fx 6100 - Before it was AMD Athlon 2 250
500gb Hard disk
Windows 7 - 64bit

Other games like battlefield 3 just run normally, everything on ultra with 50-70 stable fps. But the sims 3 doesn't work well.

(maybe is just me being paranoid, but i think that when the cpu was the 2 core, my common programs like google chrome run smoothly, and the pc start
July 20, 2012 6:32:26 AM

That 6100 should be doing better than the your old dual core. Open Task Manager (Ctrl+Alt+Del) and make sure that all six cores are showing in the performance Tab. If not read below.


"This problem seems to happen when you upgrade a CPU to an existing version of windows, Vista had this issue with upgrading from a dual core to a quad core, and even reports from the newer OS (Windows 7) is having the same problem. This tweak applies for Vista and Windows 7, and XP if your afraid to follow the Vista users.

To enable all 4/6/8 cores on your multi-core CPU, click on Start/All Programs/Accessories and click RUN, in the box type in this without the quotes "msconfig".

In the System Configuration window, click on the Boot tab and click Advanced options, where is says Number of processors click on the drop down and select the max amount of cores your CPU has. If it still says something like 2 and you have a 6 core, Uncheck the box and restart. Open up Task Manager and see if all your cores are now showing up in the Performance tab"


^^From an old post, If that does not work, Re install the game, could be vary possible that the game still thinks that you have a dual core instead of the new six core. Good Luck!
Score
0
a b Î Nvidia
July 20, 2012 7:54:21 AM

Nice info there Viking.
@ dudu631
I have seen this quite a lot over the last few days, people switching out to FX CPU's and not getting the performance bump they were expecting. I am very interested to find out if this is indeed the issue.


Mactronix :) 
Score
0
Related resources
July 20, 2012 5:40:55 PM

Actually all of 6 cores are enabled and showing performance. I re-installed the sims 3 quite a lot of times, and tryed a looot of fixes on internet.

And mactronix, i saw some performance bump, because my Battlefield 3 used to run with 25-35 fps on medium. And now i can run it on ultra(everything maxed out) with about 70-90 fps. That's a really big change.

But i don't understand this issue on the sims 3!

And yesterday, i found out that my ram memory was set to 1060, and she is 1333mhz, so I fixed this too, and the multitasking increased. Now the only big problem is this the sims 3... I have no idea what i can do!
Score
0
July 20, 2012 6:34:21 PM

Do you accidently have some insane AA settings enabled for The Sims?
Score
0
a b Î Nvidia
July 20, 2012 7:34:53 PM

Did you reinstall windows when you switched motherboard and your CPU?
Score
0
July 20, 2012 7:37:44 PM

It could be a driver issue with the card, Try a new driver from Nvidia or downgrade if already upgraded, sometimes newer drivers are garbage both from AMD/Nvidia.

Also another thing you can do is open Task Manager and find the Sims 3 in the Processes tab (Idk what the name of it would be) and right click on its process and select Set Affinity and make sure all six cores are selected, should say All CPU's and a check box.

You can also set the Priority to high, don't set it to real time, your game will more than likely crash. Remember to change these settings, you will need to have the game running!

Check the Nvidia Control Panel and make sure you don't have setting turned to high like the AA. My aunt plays the Sims on a Phenom II x4 940 3.4ghz and plays it maxed out on the HD6770, should be no reason why your getting such low performance with the CPU and GPU of yours.
Score
0
July 20, 2012 7:47:44 PM

Quote:
Do you accidently have some insane AA settings enabled for The Sims?


I'll check this on Nvidia Control Panel.

Quote:
Did you reinstall windows when you switched motherboard and your CPU?


Sure, I did Format it.

Quote:
It could be a driver issue with the card, Try a new driver from Nvidia or downgrade if already upgraded, sometimes newer drivers are garbage both from AMD/Nvidia.

Also another thing you can do is open Task Manager and find the Sims 3 in the Processes tab (Idk what the name of it would be) and right click on its process and select Set Affinity and make sure all six cores are selected, should say All CPU's and a check box.

You can also set the Priority to high, don't set it to real time, your game will more than likely crash. Remember to change these settings, you will need to have the game running!

Check the Nvidia Control Panel and make sure you don't have setting turned to high like the AA. My aunt plays the Sims on a Phenom II x4 940 3.4ghz and plays it maxed out on the HD6770, should be no reason why your getting such low performance with the CPU and GPU of yours.


My driver is up to date, i'll downgrade it and try, but before I change CPU no problem like that was happening. I'll check the cores selected and i'll post any news.

I'll try these things,thanks! Posting news soon.
Score
0
July 20, 2012 7:52:13 PM

Also I was thinking if you got any sort of overlay like Origin or Steam try to disable that in just that game and see if it runs smoother, could be the game just really performs bad on the new Bulldozers.

Do you know how much FPS your getting in the game by any chance?
Score
0
July 20, 2012 8:07:15 PM

Viking2121 said:
Also I was thinking if you got any sort of overlay like Origin or Steam try to disable that in just that game and see if it runs smoother, could be the game just really performs bad on the new Bulldozers.

Do you know how much FPS your getting in the game by any chance?


Yes, battlefield 3 is 70-90
the sims 3 is from down 15 to 65 when city overviewing.
Score
0
July 20, 2012 8:09:00 PM

Oh wow, with your system you should be playing all them games without an issue at all, I'll see if I can find anything.
Score
0
July 20, 2012 8:13:50 PM

I have a CoolerMaster 650W real, and I do monitor my CPU and GPU temperatures and they are normal:

CPU - 23º(desktop)/ 27º(on games)
GPU - 40º(desktop)/ 55º(on games)

Other games are having this issue. Like dota 2 and Skyrim. Just battlefield 3 is normally running.
And i forgot to mentiong, no steam or origin when playing the sims 3.
Score
0
July 20, 2012 9:47:56 PM

So, i've tried setting all cores, and they were already set. I tried the AntiAliasing thing, and it was on 2x, the lowest one. I tried turning off the UAC Virtualization from Windows Configuration, but no big changes from it...

Also I tried downgrading from 301.42, to 280, no changing at all. And i'm trying now to change to 301.10, (one before mine).

I'm starting to think it is something related to Directx, what do you guys think? I'm desperated, this computer is rvery new, and I bought it to play games...

I'll post soon.
Score
0
July 20, 2012 10:47:41 PM

Tried everything, even downgrading GPU drivers, no changes. Guys, I have no idea what else I can do. Please, help me!
Score
0
July 20, 2012 11:55:54 PM

Im not sure either at this point, Only thing I would do at this point is re install your OS and Update it.

And which PCI-E slot did you put your card into? Download GPU-Z here http://www.techpowerup.com/downloads/2155/TechPowerUp_G...

And make sure its running at the right bus interface, like PCI-E 2.0 x16 @ x16 2.0, should look similar to my screenshot where it says Bus interface.

http://i39.tinypic.com/2na8vlw.jpg

Now if it says something like PCI-E 2.0 x16 @ x4 2.0 then that would be your problem.
Score
0
July 21, 2012 2:55:21 AM

I had an issue replacing my dual core with my 6 core. I had to reinstall 64bit.
And you also have to make sure you reset your bios back to defult.

But try clearing your bios and cleaning up the mess your created in your registry by installing, uninstalling constantly. Update every driver, and do a disk clean, defrag, and registry clean and defrag. In that order.
This has worked in the past for me when i was learning.

Also, some games dont work well when MANY human interface devices are running.
I dont know why (would like to know) but its true. Disable things you dont ACTUALLY use. in the HID list in the device manager.

If this all fails. I say BACKUP your valuables and saved game data and reinstall Win7
After All it is a nice refreshed start with the new hardware.
Hope Win8 is better.

Keep us posted mate
cheers
Score
0
July 22, 2012 4:10:14 PM

Well, when I changed my CPU, i did reinstalled my OS. And I try to keep no programs besides the essencial while running my games, that's something i'm aware of.

I don't know how to reset my BIOS to default.

AH! My bus interface isn't that one you show. See it -> http://gpuz.techpowerup.com/12/07/22/dym.png

What i'm supposed to do?
Score
0
July 22, 2012 4:31:44 PM

I figured out that this isn't changing to 2.0 even when it's on a render test. And my CPU clock now isn't constantly 3.300Mhz x16.5 multiplier. It keeps changing...
Score
0

Best solution

July 22, 2012 8:11:43 PM

So your GTX560 is running at PCI-E 1.1.

Look for anything in the bios related to PCI-E or Gen 2 some or another, Thats what the name of it was on my DFI board, Not sure about ASRock. Either way its still strange for such a new board to run at 1.1 PCI-E interface.

You might have to disable the Onboard video all together in the bios to get full 2.0 bandwidth. Which the GTX560 can benefit from a 2.0 interface.

And your CPU will change its clocks during idle if you kept everything at stock, My x6 1100T down clocks to 800mhz changing its multi during idle or playing music at stock. That would be normal. If its doing it at full load or any load could mean that you need a bios update or have to wait till ASRock comes out with something.

If you don't like it changing like that, Disable "Cool 'n' Quiet" and "Spread Spectrum" in the bios, it will quit down clocking like that and be at a full 3.3ghz all the time.
Share
July 22, 2012 8:11:59 PM

PROBLEM SOLVED!

I reset my BIOS to default. ALL my gaming problems are gone. I realized that my motherboard doesn't support PCI-E 2.0 i guess... that's why is showing 1.1 x16 there...i think.

The point is, the source of all my problems was my BIOS. Now, it's gone, and my the sims 3 is running with about 150 fps average. Thanks a lot for all who tried to help me, and all solutions you guys gave me. I wouldn't have this fixed without your help.

Really thanks.

Just a curiosity, am I wright about the PCI-e 1.1 x16 thing or that's wrong really?

my motherboard is N68-s3 FX
Score
0
July 22, 2012 8:15:04 PM

dudu631 said:
PROBLEM SOLVED!

I reset my BIOS to default. ALL my gaming problems are gone. I realized that my motherboard doesn't support PCI-E 2.0 i guess... that's why is showing 1.1 x16 there...i think.

The point is, the source of all my problems was my BIOS. Now, it's gone, and my the sims 3 is running with about 150 fps average. Thanks a lot for all who tried to help me, and all solutions you guys gave me. I wouldn't have this fixed without your help.

Really thanks.

Just a curiosity, am I wright about the PCI-e 1.1 x16 thing or that's wrong really?

my motherboard is N68-s3 FX



Well PCI-E 1.1 can effect FPS a tiny bit, more like 2 - 4% slower then the 2.0 PCI-E, You wont see much on a different between the 2 interfaces unless your running something like a GTX 590 or HD 6990 or something of the sort.


EDIT: I can't seem to find anything stating that it supports PCI-E 2.0, and can't find anything about PCI-E 1.1 on that board, Most sites just say its a PCI-E x16 lane, and nothing else.
Score
0
July 22, 2012 8:35:14 PM

Viking2121 said:
Well PCI-E 1.1 can effect FPS a tiny bit, more like 2 - 4% slower then the 2.0 PCI-E, You wont see much on a different between the 2 interfaces unless your running something like a GTX 590 or HD 6990 or something of the sort.


EDIT: I can't seem to find anything stating that it supports PCI-E 2.0, and can't find anything about PCI-E 1.1 on that board, Most sites just say its a PCI-E x16 lane, and nothing else.


Yeah, i didn't find either. But i'm happy to have found the solution to the problem I was having. I'm satisfied with my frames per second in my games now. And thanks for the Information about the cool'n'quiet thing. Very useful.

Thanks a lot for all who helped me(even who only replied once), and a special thanks for you viking2121, who helped me since the beginning and always replied me. :D 

Problem solved!!
Score
0
July 22, 2012 8:37:21 PM

Your Welcome! And have fun!
Score
0
July 28, 2012 12:14:38 AM

Best answer selected by dudu631.
Score
0
July 29, 2012 3:51:57 AM

I had a new problem. When i disable Spread Spectrum and Cool n quiet, CPU doesn't run stable at 3.3ghz. It appears to be more unstable.
Score
0
a c 172 Î Nvidia
a b À AMD
July 29, 2012 9:46:12 AM

This topic has been closed by Mousemonkey
Score
0
!