Sign in with
Sign up | Sign in
Your question

Graphics Card not showing up in dxdiag/msinfo/GPU-Z! Help please!

Last response: in Graphics & Displays
Share
July 20, 2012 3:00:31 PM

Hi all,

I recently built a computer with a Radeon HD6870 graphics card. However, when I go into dxdiag, msinfo or GPU-Z, my Display unit shows up as the Intel HD Family? I downloaded the AMD Catalyst driver off the website so I don't know why this is going on...anyone have any answers?

I don't know how to post images here but I can try and help you guys out.

By the way, my motherboard is a Gigabyte Z77-D3H.

Thanks guys! :??: 
a b U Graphics card
July 20, 2012 3:02:36 PM

first connect your display connector to your graphic card
then go to the bios and disable igpu
or if you havent installed drivers then do so
a c 290 U Graphics card
July 20, 2012 3:03:13 PM

I second panwala. You need to connect your monitor directly to your graphics card, and not the motherboard.
Related resources
July 20, 2012 3:05:21 PM

My monitor is quite old and so I'm using a VGA connector, of which there doesn't seem to be a similar fitting one on my motherboard :S
Thanks guys, I'll try and search for a different cable and get back to you.

Edit: VGA connector as opposed to DVI-D. The only ports on my monitor are VGA and DVI-D.
I don't have a VGA to DVI-D connector and so can't currently connect my monitor to the graphics card, instead of the motherboard.

Any other solutions? Thanks for your help so far.
July 20, 2012 3:29:49 PM

Anyone got any ideas?
a c 290 U Graphics card
July 20, 2012 3:32:39 PM

It's impossible to use graphics card if you're connecting monitor to the motherboard. Sorry, but getting a proper cable is the only option.
July 20, 2012 3:34:09 PM

Ok, thanks. So a DVI-D cable or VGA to DVI-D adaptor?

My graphics card has DVI-D and HDMI, my monitor has DVI-D and VGA.
a c 290 U Graphics card
July 20, 2012 3:35:13 PM

For best quality results, I'd suggest a DVI-D cable.
July 20, 2012 3:42:35 PM

Thanks, I've ordered one. Do I still have to go into BIOS and disable the iGPU as panwala described?

Thanks again!
a b U Graphics card
July 20, 2012 3:43:15 PM

you try and tell us!
a c 290 U Graphics card
July 20, 2012 3:44:30 PM

you don't. It should detect it automatically.
!