Sign in with
Sign up | Sign in
Your question
Solved

HD 5850 Bad Graphics, Pixilated Square Pattern

Last response: in Graphics & Displays
Share
July 20, 2012 5:42:57 PM

My HD 5850 is running this weird sqaure pattern in the background of several games I am playing. These games are SCII, Diablo 3, and Skyrim. I have reformatted the hardrive and tried to update drivers several times. With Catalyst Control Center, it won't even let me get to the overclocking options any more. So at the moment nothing is overclocked and I reset to default optimized settings on everything. These graphics only appear on certain objects. Is my GPU dieing? Thanks for all your help and suggestions, I have tried to look into this for a while now.


AMD Phenom II x4 955be
Gigabyte GA
Corsair Vengeance 8gb
Thermaltake 850w
Radeon HD 5850
Corsair SSD
HAF Case
a b U Graphics card
July 20, 2012 6:36:16 PM

Wipe the old drivers off your computer using driver wiper. Then install the latest set.

Try reseating your GPU. How are your temps?
a b U Graphics card
July 20, 2012 7:44:08 PM

A quick test to see if your GPU is having problems (or something related) you can run Furmark. Usually its the first thing I have people do. Makes everyone's job a lot easier to know what temps you are getting and helps narrow things down.
Related resources
Can't find your answer ? Ask !
July 20, 2012 9:04:37 PM

I have OCCT that I use. When gaming it never gets above 60c. When I stress test with ambient temperatures around 72-75f I get 90c and lower depending on the length of the test. So I'm pretty sure it's not temperature related. I didn't think it was drivers because even after reformatting and downloading at least one successful driver update it still had the same results. Right now I have catalyst 12.6 installed with drive package 8.98-120611a-141402C-ATI.
July 20, 2012 9:05:55 PM

Also, my card is a powercolor 5850.
July 20, 2012 9:50:28 PM

http://imgur.com/ssmYQ

This link should show you guys exactly what it looks like. Sorry for all of the posts, but this should further clarify.
a b U Graphics card
July 21, 2012 1:40:03 AM

How is your card connected to your monitor? VGA, DVI, DVI to VGA adapter?
July 21, 2012 4:22:06 AM

DVI adapter to VGA!
a b U Graphics card
July 21, 2012 5:46:36 AM

I've heard stories of heat off the video card messing with those. Try plugging it into a different DVI Port, or buy a DVI cable maybe.
July 23, 2012 9:20:32 PM

Just tried using HDMI to DVI with adapter, HDMI end into the monitor. No dice.
a b U Graphics card
July 25, 2012 7:41:51 PM

Hmm, this is a toughy. Have you insure that you power cables are all plugged in? Tried it in different PCI-E slots? Maybe even try going into bios and making sure you PCI-E settings are correct? Did you overclock you FSB?
July 25, 2012 10:23:36 PM

How do I make sure my PCI-E settings are correct? I don't know much about that. I went into my bios and hit "f7" optimized defaults. So my FSB should be where it is supposed to be, 200. I will try a different PCI-E slot on the motherboard, haven't done that yet. Since many people have complained about this same graphic problem in skyrim, I feel like it is a driver issue that is not universally fixed yet.
July 27, 2012 9:54:14 PM

I replaced the PCI cable to my Thermaltake power supply giving it a dedicated connection to the GPU, and I just tried a DVI cable to my Acer monitor. So no adapter. Still the same results. I give up. This card is about to get bricked.

Best solution

a b U Graphics card
July 28, 2012 1:35:00 AM
Share

Probably for the best, it might just have been a card that was binned to high. Can you get it replaced under warranty?
March 4, 2013 1:40:56 PM

I'm having the same problem with my 7950! The squares are white, pink, blue or red, and the only show up once in a while for a second, it's very annoying. But I borrowed the exact same card from a friend and it does the same, so I'm guessing it's not a graphic card problem.
March 4, 2013 2:02:49 PM

Did you manage to solve your problem?
March 4, 2013 3:13:38 PM

Yakvza said:
Did you manage to solve your problem?


Unfortunately I have not. I did read something some time ago that may have provided me a lead. This guy said something about hating the new dx 11 ATI cards (which would have started with the 5xxx series I beleive), because he said they would not play his dx9 games without glitching up. I think all of the games I mentioned, e.g blizzard games, skyrim, are all dx9 games.
March 4, 2013 6:27:26 PM

But just so we're clear, that glitch with the squares only pops up once in a while for a second or less, right? I had this problem with dead space 3 and now Tera :( 
March 4, 2013 6:31:38 PM

I tried everything, even tried another 7950. I'm starting to think it may be something wrong with my motherboard.
Don't know if it helps somehow but my specs are:

Asus P8h67 M-Pro
i7 2600
16gb ram (8 kingston hyperx + 8 corsair vengeance)
SSD kingston (the glitch started soon after I got it but I doubt there's a conection)
!