Sign in with
Sign up | Sign in
Your question

WinXP Pro Unattended Installation Problem

Last response: in Windows XP
Share
Anonymous
July 30, 2005 6:14:50 AM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windowsxp.help_and_support (More info?)

I am trying to create an unattended installation WINNT.SIF file that
instructs Windows Setup to apply certain preferences and settings when
installing on my PC.

I can create the bootable CD fine etc, but am having problems with certain
elements of my WINNT.SIF not actually working during the setup.

[Data]
AutoPartition=0
MsDosInitiated="0"
UnattendedInstall="Yes"
AutomaticUpdates=1

[Unattended]
UnattendMode=ProvideDefault
OemPreinstall=Yes
OemSkipEula=Yes
NoWaitAfterTextMode=1
NoWaitAfterGUIMode=1

WaitForReboot="No"
TargetPath=\WINDOWS
DriverSigningPolicy=Ignore
OemPnPDriversPath=drivers\SATA\WinXP
KeyboardLayout="United Kingdom"

[GuiUnattended]
AdminPassword="xxxxx"
OEMSkipWelcome = 1
TimeZone=085

[UserData]
ProductKey="xxxx-xxxxx-xxxxx-xxxxx-xxxxx"
FullName="mark"
OrgName=""
ComputerName=MARK

[Display]
BitsPerPel = 32
Vrefresh = 75
Xresolution = 1280
Yresolution = 1024

[TapiLocation]
CountryCode=44
AreaCode=0121

[RegionalSettings]
Language=0809
LanguageGroup=0809

[Identification]
JoinWorkgroup=WORKGROUP

[Components]
msnexplr=Off
freecell=Off
hearts=Off
minesweeper=Off
pinball=Off
solitaire=Off
spider=Off
zonegames=Off
msmsgs=Off

For example, the keyboard layout and regional settings all work fine and are
set to the UK during installation, however, the time zone always remains on
(GMT-08:00) Pacific Time (US & Canada) despite me setting it to 085, which
is supposed to be GMT.

Similarly, the display settings are not set to the resolution, depth and
refresh rate that i have set them to upon Windows starting and the games in
the components section are still installed despite me setting them to Off.

Also, when AutomaticUpdates=Yes, the "Help Protect Your PC" page
should not display, however, it does. Could this be because i have not set
values for the "Your Name" box and also stated that i do not want to
register
Windows? Therefore, it cannont skip this screen as all of the values in it
have
not been stipulated?

I have tried the settings with spaces between them and also with and without
quotation marks, with no success. So i am confused as to why some of the
settings work and yet others do not.

What am i doing wrong???

Any help would be much appreciated.
Anonymous
July 30, 2005 6:14:51 AM

Archived from groups: microsoft.public.windowsxp.customize,microsoft.public.windowsxp.help_and_support (More info?)

"andy k" <andy145@hotmail.com> wrote in message
news:D cenqp$5v4$1@nwrdmz03.dmz.ncs.ea.ibs-infra.bt.com...
>I am trying to create an unattended installation WINNT.SIF file that
> instructs Windows Setup to apply certain preferences and settings when
> installing on my PC.
>
> I can create the bootable CD fine etc, but am having problems with certain
> elements of my WINNT.SIF not actually working during the setup.
>
> [Data]
> AutoPartition=0
> MsDosInitiated="0"
> UnattendedInstall="Yes"
> AutomaticUpdates=1
>
> [Unattended]
> UnattendMode=ProvideDefault
> OemPreinstall=Yes
> OemSkipEula=Yes
> NoWaitAfterTextMode=1
> NoWaitAfterGUIMode=1
>
> WaitForReboot="No"
> TargetPath=\WINDOWS
> DriverSigningPolicy=Ignore
> OemPnPDriversPath=drivers\SATA\WinXP
> KeyboardLayout="United Kingdom"
>
> [GuiUnattended]
> AdminPassword="xxxxx"
> OEMSkipWelcome = 1
> TimeZone=085
>
> [UserData]
> ProductKey="xxxx-xxxxx-xxxxx-xxxxx-xxxxx"
> FullName="mark"
> OrgName=""
> ComputerName=MARK
>
> [Display]
> BitsPerPel = 32
> Vrefresh = 75
> Xresolution = 1280
> Yresolution = 1024
>
> [TapiLocation]
> CountryCode=44
> AreaCode=0121
>
> [RegionalSettings]
> Language=0809
> LanguageGroup=0809
>
> [Identification]
> JoinWorkgroup=WORKGROUP
>
> [Components]
> msnexplr=Off
> freecell=Off
> hearts=Off
> minesweeper=Off
> pinball=Off
> solitaire=Off
> spider=Off
> zonegames=Off
> msmsgs=Off
>
> For example, the keyboard layout and regional settings all work fine and
> are
> set to the UK during installation, however, the time zone always remains
> on
> (GMT-08:00) Pacific Time (US & Canada) despite me setting it to 085, which
> is supposed to be GMT.
>
> Similarly, the display settings are not set to the resolution, depth and
> refresh rate that i have set them to upon Windows starting and the games
> in
> the components section are still installed despite me setting them to Off.
>
> Also, when AutomaticUpdates=Yes, the "Help Protect Your PC" page
> should not display, however, it does. Could this be because i have not
> set
> values for the "Your Name" box and also stated that i do not want to
> register
> Windows? Therefore, it cannont skip this screen as all of the values in
> it have
> not been stipulated?
>
> I have tried the settings with spaces between them and also with and
> without
> quotation marks, with no success. So i am confused as to why some of the
> settings work and yet others do not.
>
> What am i doing wrong???
>
> Any help would be much appreciated.
>
>
>
>

This what mine looks like and have no problems.

[Data]
Autopartition = 0
FloppyLess = 1
MsDosInitiated = 0
UnattendedInstall = Yes

[Unattended]
UnattendMode = FullUnattended
UnattendSwitch = Yes
OemPreinstall = Yes
OemSkipEula = Yes
FileSystem = *
WaitForReboot = No
NoWaitAfterTextMode = 1
NoWaitAfterGUIMode = 1
TargetPath = Windows

[SystemRestore]
MaximumDataStorePercentOfDisk = 5

[GuiUnattended]
AutoLogon = No
EncryptedAdminPassword = No
AdminPassword = "***********"
TimeZone = 010
OEMSkipRegional = 1
OemSkipWelcome = 1

[Components]
iis_common = On
iis_inetmgr = On
iis_pwmgr = Off
iis_doc = Off
iis_www = On
Iis_www_vdir_printers = Off
Iis_www_vdir_scripts = Off

[UserData]
ProductKey = "*****-*****-*****-*****-*****"
ComputerName = WTC002
FullName = "****************"
OrgName = "*******************"

[RegionalSettings]
Language = 1009

[Networking]

[Identification]
JoinWorkgroup = mshome

--
William
!