Sign in with
Sign up | Sign in
Your question

Did my cpu go bad?

Tags:
Last response: in CPUs
Share
January 23, 2013 6:21:03 PM

So today my computer randomly shut off. When I first turned it on, it immediately turned off and turned back on and after the initial screen , it gave me a message about my voltages and my cpu speed. I didn't know what to do so I just pressed ok and thought it would just boot up normally. Well it shuts off again and now it does not go past the initial startup screen(the screen that shows press del for bios and f12 for something) and i can't get into bios because it just turns off after that screen. I'm not sure if it is my power supply as i've tried doing the paper clip test and it works. I've also tried the ram(removing one, turning on and vice versa) to no avail.

My computer specs are :

cpu: i5 2500k oc'd to 4.2
psu: CMPSU-750TX
Gigabyte GA-Z68AP-D3 LGA 1155 Z68 ATX Intel Motherboard
Corsair XMS3 Series 8GB DDR3-1600

sorry if i left out anything im typing this on my phone

More about : cpu bad

a c 190 à CPUs
January 23, 2013 6:31:13 PM

It is extremely rare for a CPU to go bad and it sounds more like a PSU issue to me. So first step is to check to make sure that the PSU isnt bad. If you can borrow an extra PSU and test it but running that. If that tests out I would check the board by restoring the Bios. Once you have done all this and the processor is running at stock you can call our technology support at 916-377-7000.
m
0
l
January 23, 2013 6:43:11 PM

Alright I'll try that thanks
m
0
l
!