Sign in with
Sign up | Sign in
Your question
Closed

My turbo boost is not working properly

Last response: in CPUs
Share
January 26, 2013 3:03:21 AM

I have an ASUS K55vm laptop it has the following configurations:
i7 3610
8GB ram 1600
nVidia gt 630M 2 GB

The problem i am facing here is that when i first played some games like Ghost Recon Future Soldier It was very smooth and i was getting almost 30 - 35 fps but now when i play the same game even the same mission the fps are down to 10 fps . One thing i noticed that at first the was a lot of heat generating but now while i play there is no heat generation the laptop is very cool. I think that at first my laptop's turbo boost was working thats why there was heat and 35 fps , but now turbo boost is not working so there is no heat and low fps.

Please help me in this thing , i am frustated because of this.

thanks in advance.
January 26, 2013 3:19:15 AM

i do not know about turbo boost... but i do know intel speedstep

but even so, maybe because of your power plan?

try to check for cpu usage limitation. (windows 7 based) right-click your power icon on notification bar then click power options. make sure your plan is High performance (common) or ASUS High speed power plan (or similar) selected. then try to play the game again (or stress it with Prime95)

if the game still slow or the stress is not in 100% cpu usage, click change plan setting next to power plan you had selected. click change advanced power settings then scroll down until you find Processor power management. Click it and click maximum processor state and make sure on both on battery and plugged in is shows 100%. if not, adjust the value to 100. [optional] click minimum processor state and change both values to 100. test it again with your game or stress it out. for the best, always plugged in your charge. when playing games or doing intensive cpu usage.

normally with nowadays notebook, it automatically change the power plan to high performance or power saver depends on your application. most high-end laptops or with third-party programs like BattCursor can change your power plan automatically when plugged in.
Score
0
January 26, 2013 3:39:06 AM

Ikmalhidayat said:
i do not know about turbo boost... but i do know intel speedstep

but even so, maybe because of your power plan?

try to check for cpu usage limitation. (windows 7 based) right-click your power icon on notification bar then click power options. make sure your plan is High performance (common) or ASUS High speed power plan (or similar) selected. then try to play the game again (or stress it with Prime95)

if the game still slow or the stress is not in 100% cpu usage, click change plan setting next to power plan you had selected. click change advanced power settings then scroll down until you find Processor power management. Click it and click maximum processor state and make sure on both on battery and plugged in is shows 100%. if not, adjust the value to 100. [optional] click minimum processor state and change both values to 100. test it again with your game or stress it out. for the best, always plugged in your charge. when playing games or doing intensive cpu usage.

normally with nowadays notebook, it automatically change the power plan to high performance or power saver depends on your application. most high-end laptops or with third-party programs like BattCursor can change your power plan automatically when plugged in.



thanks for the advice but its not working.

any other ideas?

and how to use Prime 95
Score
0
Related resources
a b à CPUs
a b D Laptop
January 26, 2013 4:22:52 AM

the most likely problem is that your switchable graphics aren't working, and the game is running on the HD4000 instead of the 630M hence the heat reduction. This could be because of a driver problem, the 630M being broken, or you power plan settings being wrong as said above. You should be able to force if to use the 630 in the gpu drivers
Score
0
a c 79 à CPUs
January 26, 2013 6:09:39 AM

I agree with both Ikmal and Unksol. Enter your BIOS and check whether your VGA settings are set to use your 630M as your primary grapics device.
Score
0
January 26, 2013 6:10:49 AM

unksol said:
the most likely problem is that your switchable graphics aren't working, and the game is running on the HD4000 instead of the 630M hence the heat reduction. This could be because of a driver problem, the 630M being broken, or you power plan settings being wrong as said above. You should be able to force if to use the 630 in the gpu drivers



thank you for your reply but can you please tell me how can i force to use 630M?
Score
0

Best solution

a b à CPUs
a b D Laptop
January 26, 2013 6:44:02 AM

palashrc0945 said:
thank you for your reply but can you please tell me how can i force to use 630M?

there are two versions, actual switchable graphics, or optimus. If its switchable its in the BIOS, which you want set to either auto or dedicated

If its optimus its in the nvidia control panel. I believe via the application profiles. It SHOULD work by default but if you updated drivers our something it may have gotten confused. I don't have one to look at but heres a description on an older version of the driver. It still.should be under application profiles

Http://forum.notebookreview.com/gaming-software-graphic...
Share
January 26, 2013 8:15:56 AM

satyamdubey said:
I agree with both Ikmal and Unksol. Enter your BIOS and check whether your VGA settings are set to use your 630M as your primary grapics device.



But at first when i was using the laptop games were smooth and i did nothing.
Score
0
January 26, 2013 8:52:44 AM

Best answer selected by palashrc0945.
Score
0
!