Sign in with
Sign up | Sign in
Your question

Motherboard won't start with power button (No beep codes either)

Last response: in Components
Share
January 26, 2013 3:39:05 PM

Hello, I'm building a PC for the first time and have fitted the motherboard and PSU to the case, as well as the wires for the front plate to the appropriate pins on the motherboard (Power switch, power light, reset button, HDD indicator, etc).

However, when I press the power button, nothing happens. No fans, LEDs, no beeps, nothing. The fans/LEDs and Power LEDs do start however when I manually jump the PSU (still no beeps though). It has no processor or RAM in it at the moment, so I know it won't boot to BIOS. I just want it to turn on so I know the parts I bought all work.

What am I doing wrong? Please help!
a c 243 ) Power supply
a b V Motherboard
January 26, 2013 4:00:55 PM

MatrixJ21 said:
Hello, I'm building a PC for the first time and have fitted the motherboard and PSU to the case, as well as the wires for the front plate to the appropriate pins on the motherboard (Power switch, power light, reset button, HDD indicator, etc).

However, when I press the power button, nothing happens. No fans, LEDs, no beeps, nothing. The fans/LEDs and Power LEDs do start however when I manually jump the PSU (still no beeps though). It has no processor or RAM in it at the moment, so I know it won't boot to BIOS. I just want it to turn on so I know the parts I bought all work.

What am I doing wrong? Please help!

Attempting to start a system without a cpu
January 26, 2013 4:04:42 PM

delluser1 said:
Attempting to start a system without a cpu


Shouldn't it still turn on if there's no CPU? Won't it just not reach the BIOS?
Related resources
!