3GB EVGA GTX 580 Black Screen NO BIOS on monitor?

Okay i have no idea, I just got this system, and for some reason, everything is working fine, fans light up, fans are spinning, the SSD and HDD are spinning even the GPU's fan is spinning BUT

1. I have no picture on my monitor....

2. I dont even have any BIOS its as if nothing is plugged in to the GPU...


3. I tried using a GTX 260 and still nothing...


What am I doing wrong? :cry: :cry: :cry:


I tested a mini-HDMI to HDMI, mini-HDMI to DVI, DVI to DVI, and still nothing! Anybody know what Iam doing wrong?
7 answers Last reply
More about evga black screen bios monitor
  1. Prebuilt or build yourself? Power from PSU connected to card(s)?
  2. rolli59 said:
    Prebuilt or build yourself? Power from PSU connected to card(s)?



    Built myself. Yes I have a 8-pin and a 6-pin hooked to the 580....
  3. And the same with the GTX260, then it looks like you might have a motherboard problem. Run through this guide step by step then post back http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems
  4. Pull the video card out and run your monitor straight from the motherboard. Once you get it to post, load up your OS and install the drivers for the video card. After that shut down the computer and install your video card. When you power it back up it should detect the new hardware and you should be good at that point.
  5. AaronC8319 said:
    Pull the video card out and run your monitor straight from the motherboard. Once you get it to post, load up your OS and install the drivers for the video card. After that shut down the computer and install your video card. When you power it back up it should detect the new hardware and you should be good at that point.



    The motherboard has no display outs... like no vga or dvi....


    More specs on the system:

    i7 2600K
    16GB G-SKILL Ram (2 X 8GB)
    128GB Crucial SSD
    1TB Samsung HDD
    Asus P8Z68 Deluxe
    Corsair 850w PSU
    Antec 902 Case
    3GB EVGA GTX 580
  6. That would not work anyway since the driver install is just going to quit because it will not find any compatible product! The card should display on default VGA drivers.
  7. Try starting it with only 1 stick of memory installed into the closest slot to the CPU
Ask a new question

Read More

Graphics Cards Monitors Graphics