Sign in with
Sign up | Sign in
Your question
Closed

How do I enable my laptop's dedicated graphics card

Tags:
  • Nvidia
  • Graphics Cards
  • Graphics
Last response: in Graphics & Displays
Share
July 26, 2012 7:38:18 AM

I recently purchased a Lenovo ideapad Y580. It has an i7 3610qm processor, 8gb of ram, and a geforce gtx 660m graphics card - as well as a Intel HD 4000 integrated graphics card. I've downloaded several steam games (tf2, brink, bfbc2, l4d2, gta 4) and while some of them play alright, they are definitely not what I expected given the graphics card I have. How do I disable this switchable graphics horse ****? Every game I play insists on using the integrated graphics. I tried going to device manager and disabling the integrated video card but got a black screen and had to take out my battery and reboot my laptop. I went to the bios and tried to switch the display setting from switchable graphics to UMA or something like that, but to no avail. I've searched all over the internet and cannot find the solution to my problem. It's very frustrating. Oh and I tried installing nvidia drivers but the website said all the driver were up-to-date. Someone please help, I'm at wit's end.

More about : enable laptop dedicated graphics card

a b U Graphics card
July 26, 2012 8:24:27 AM

UMA, does it give you a priority list on graphics cards? if it does set IGPU to the last
Score
0
July 26, 2012 9:07:20 AM

nvm I fixed it by fiddling with the nvidia controller and plugging in the power adapater. I guess it only works when the power adapter is on
Score
0
a b U Graphics card
July 26, 2012 10:47:46 AM

that would make sense, doubt it would last more than an hour otherwize :p 
Score
0
Related resources
!