Sign in with
Sign up | Sign in
Your question

HD7950 and 12.6 driver taskbar flickering

Last response: in Graphics & Displays
Share
July 26, 2012 5:05:35 PM

Alright, so I seem to have this funky issue with my MSI Twin Frozr III HD7950 I just got back from newegg after an RMA for a defective 7950. Whenever I am in a full screen game or even netflix the area where the task bar is will randomly flicker black and white garbled mess for milliseconds at a time. In some games it does it and some games it doesn't. I'm starting to think it is a driver issue with 7 series gpu's because it did it to my old defective card (just had overheating issues) and it also does the same thing to my brother in his desktop with the same 12.6 driver and the same msi hd7950 that he bought. I went from a 6950 in my desktop and didn't have any of these issues with the same driver. Has anyone else run into this?

More about : hd7950 driver taskbar flickering

July 26, 2012 7:16:00 PM

probably it is just a driver issue, do a clean install of the drivers to make sure they are working properly.
m
0
l
July 26, 2012 7:18:02 PM

If new drivers don't fix it, try switching to the classic theme for a while, I used to have similar problems before I changed mine.
m
0
l
Related resources
July 26, 2012 7:22:56 PM

Okay, when I get home I will give it a try. Thanks for the reply!
m
0
l
February 7, 2013 2:02:01 PM

ISSUE SOLVED WITH MULTIPLE FIXES



Ok Guys, Im going to be updating how I fixed the issue for those that read, My monitor is a 1080p 75hz monitor, even though I KNOW its 60hz The Catalyst ( CCC )
Program ( EIED ) Was telling me it was 75hz. So I manually set it to 60hz and everything appeared fine. However the flickers started,

I donwloaded software called Radeon Pro and created a new profile.

I click add new profile, when to the ATI folder and added it. Forced the settings I wanted like in CCC and disabled overdrive ( It still downclocks which is nice )
however this is just personal taste, what actually solved the issue was there was an option to manually force a refresh rate of 60Hz.

All I do now is run the profile just to make sure each time ( Im sure its auto anyway) and the flicker has stopped. The reason I believe the issue was happening was my FPS were going past 75, then down to 50 quickly in fast games like SC2 and LoL and the flicker happened. So the refresh rates were getting confused even though it said 60hz in CCC and I tried Vsync.

ALSO!

Coinciding with the fix I also set my games to borederless at the same time of doing the fix mentioned above so that may be the fix or the RadeonPro thing. Yet to test it fullscreen so try that.


Authough forcing 2d clocks didnt work for me, here is how to do it.
Open CCC, top left make a new profile, Close CCC.

Enable Hidden folders ( Search folder options )

The go to Your name on your PC -
APP Data
LOCAL
ATI
and go to your new Profile
EDIT IN NOTEPAD


and look for

<Property name="Want_0" value="30000" />
<Property name="Want_1" value="80000" />
</Feature>
<Feature name="PowerControl_PCI_VEN_1002&DEV_679A&SUBSYS_27601462&REV_00_4&BAB4994&0&0008A">
<Property name="Want" value="0" />
</Feature>
<Feature name="MemoryClockTarget_PCI_VEN_1002&DEV_679A&SUBSYS_27601462&REV_00_4&BAB4994&0&0008A">
<Property name="Want_0" value="15000" />



Now look for this

Now the 30000
and 15000 part are your idle clock speeds, just raise them or make them match your cards default clock speeds,

Like so


<Property name="Want_0" value="80000" />
<Property name="Want_1" value="80000" />


now this didnt work for me as my above method did, but it may work for some,
remember though this means your card with be a little bit hotter ( didnt happen to me in testing though )


You can also raise the two voltages to stay the same.
But again the above RadeonPro methode worked for me.


Thought I would be a nice guy and update how I solved it for others having issues.



Peace, ZII

Youtube.com/videofletcher
m
0
l
!