Sign in with
Sign up | Sign in
Your question
Solved

Red dots apearing on screen HD7970

Last response: in Graphics & Displays
Share
July 28, 2012 7:04:06 PM

I recently purchased a MSI HD7970 Lightning, and today 07/28/12 I turned the computer on to see tons of red dots on the logo screen and windows loading screen, as well as in browsers and other apps with underlying dark to black colors. They move with the window the red dots are not stuck in one place.
My system was a complete new build from newegg.

Asus Sabertooth 990FX
MSI HD7970 Lightning
Corsair AX1200 PSU
Corsair Vengeance RAM 32gb
AMD FX-8150
CM HAF X 942
Corsair H100 Cooler
OCZ Vertex 4 128gb SSD

I have the latest drivers installed for mobo, and video card. BIOS Updated.
Temps on the card are fantastic Idle @ 32c, CPU @ 28c Idle.
July 28, 2012 7:56:26 PM

I've read in other places, this might be do to failing video memory, is there any type of diagnostics I can perform?
m
0
l
July 28, 2012 8:03:10 PM

Well, you can always RMA it back to Newegg.
m
0
l
Related resources
July 28, 2012 8:09:03 PM

Deemo13 said:
Well, you can always RMA it back to Newegg.

I shut the system down, waited a minute and fired it back up. The red dots on bios logo screen and windows loading screen seemed to increase exponentially. But there are none appearing in browsers anywhere at the moment. My question now being, is this going to be a progressive problem? Or simply as you said, RMA the card and no longer worry on the issue?
m
0
l

Best solution

July 28, 2012 8:15:45 PM

Yea, RMA the vid card.
Share
July 29, 2012 8:13:49 PM

Best answer selected by INeedSomeAdvice.
m
0
l
!