Sign in with
Sign up | Sign in
Your question

Sound not working through tv since I got my GTX550 Ti

Last response: in Graphics & Displays
Share
July 29, 2012 4:57:00 PM

Hi guys,

I've been using a radeon HD 5770 and had it connected to my TV via a DVI to HDMI cable, because the DVI doesn't carry the sound I had a standard 3.5mm to 3.5mm cable going from my computer to the TV to carry the sound.

My friend gave me his GTX550 Ti cause he's just upgraded, I installed it and the picture comes through the TV ok but for some reason the sound doesn't. If I unplug the the HDMI cable from the TV then the sound comes through fine, but for some reason as soon as the HDMI is plugged in again it overrides the sound!?!

Anyone have any idea why, or what I can do to rectify it?

On a side note what do you think would be the better card? There doesn't seem to be too much between them and if this is going to cause me a lot of hassle then I'll just stick with the Radeon.

Thanks a lot

David

More about : sound working gtx550

July 29, 2012 4:59:17 PM

YOU HAVE TO INSTALL THE THE DRIVERS FOR THE HDMI ON YOUR CARD FIRST!
a b Î Nvidia
July 29, 2012 5:07:42 PM

Yes, uninstall the AMD drivers first, then install the latest Nvidia drivers that come with the HD sound drivers needed for sound over HDMI.


Also, in the Sound Properties, you need to set the Nvidia HD sound as the main sound processor too.
Related resources
July 29, 2012 5:35:19 PM

El Tigre said:
Yes, uninstall the AMD drivers first, then install the latest Nvidia drivers that come with the HD sound drivers needed for sound over HDMI.


Also, in the Sound Properties, you need to set the Nvidia HD sound as the main sound processor too.



Hmm unfortunately I have done all of that. I made sure I uninstalled the catalyst control suite before I installed the drivers for the GTX and then updated to the latest off their website (v. 301.42 with 1.3.16.0 for the HD audio) and in the sound properties it's set to be the default.

" alt="" class="imgLz frmImg " />

The thing I find odd is how it works when the HDMI is unplugged and also works through another HDMI channel if the PS3 isn't turned on.
a b Î Nvidia
July 29, 2012 5:45:47 PM

Set the LG TV-0 to the default sound processor and it should work.

July 29, 2012 6:17:00 PM

I tried re-installing the drivers using the clean install option, but to no avail. When I go into the sound properties you'll notice there's no sound level bar next to the TV, the set default option is also greyed out. If I right click I can't actually choose any of the options (cause they do nothing) not the set as default, configure speakers or the test...

Very odd
a b Î Nvidia
July 29, 2012 6:19:54 PM

Hmm, it may be an issue with your TV then, try it on another TV with HDMI and see if you get the same results.

Also make sure there are no other cables connected to any sound ports besides the HDMI on your computer.
July 29, 2012 6:24:27 PM

take out the 3.5mm cable its not needed anymore.... HDMI carries the audio!
July 29, 2012 6:59:01 PM

El Tigre said:
Hmm, it may be an issue with your TV then, try it on another TV with HDMI and see if you get the same results.

Also make sure there are no other cables connected to any sound ports besides the HDMI on your computer.



The 3.5mm cable for the sound is connected to the port on my motherboard, not a separate soundcard so I don't have anything connected to any of the HDMI ports on my computer.



paddys09 said:
take out the 3.5mm cable its not needed anymore.... HDMI carries the audio!


I'm not using straight HDMI, I'm using a DVI to HDMI convertor (my TV is on the other side of the room and I didn't have the money at the time to get a 10m HDMI cable.



I don't have another HDMI TV so testing that would be awkward. The thing I'm finding odd is that this morning before I changed graphics cards it was working fine but now it's not, so I don't think it's anything to do with the TV (especially as I can hear the sound with the video cable pulled out of the TV, or on the other HDMI channel)
July 29, 2012 7:02:53 PM

Some cards have the ability to recognize a DVI to HDMI cable and process the sound to be transmitted along it.

Just try it with the 3.5mm cable removed from your mobo and TV, if sound is still not coming from the TV itself, restart the computer with the TV on.
July 29, 2012 7:12:19 PM

paddys09 said:
Some cards have the ability to recognize a DVI to HDMI cable and process the sound to be transmitted along it.

Just try it with the 3.5mm cable removed from your mobo and TV, if sound is still not coming from the TV itself, restart the computer with the TV on.


Nope unfortunately that didn't work either :-(
July 29, 2012 7:21:36 PM

Right click the desktop, select Nvidia control panel, look in the section titled "set up digital audio", turn on audio on the dvi port
July 29, 2012 7:46:53 PM

paddys09 said:
Right click the desktop, select Nvidia control panel, look in the section titled "set up digital audio", turn on audio on the dvi port


Already done too I'm afraid. If you look at the picture I put on this topic earlier though you'll see that in the Sound Settings there's no sound level bar and I can't select any of the options for the TV.
July 29, 2012 7:56:57 PM

Sorry missed that post, I dunno, from here I would be trying a standard hdmi cable just to be sure that the card is definitely handling the sound and not the motherboard.

Also check in your Device manager and make sure the Nvidia audio drivers are enabled. Can't think of anything else.
July 29, 2012 8:16:51 PM

paddys09 said:
Sorry missed that post, I dunno, from here I would be trying a standard hdmi cable just to be sure that the card is definitely handling the sound and not the motherboard.

Also check in your Device manager and make sure the Nvidia audio drivers are enabled. Can't think of anything else.


Yeah all the drivers are enabled. Like I said the thing that's odd is that if I unplug the HDMI from the TV then the audio starts playing, so it's like the video overrides the audio for some reason and I can't see any options on the NVIDIA control panel to change any settings around that.

Oh well thanks for your help and hopefully someone else will notice this post and maybe have the answer for me

Don't...

Bump posts


http://www.tomshardware.com/forum/283384-33-read-first
July 31, 2012 10:31:50 PM

I apologise for bumping the post, I admit I forgot the rule :-/

It seems it doesn't rain but pours. I have found out that my hard drive has actually corrupted now! I used to get the occasional blue screen on start-up, but didn't think too much of it cause it was random and quite rare, but today it would not load up and I constantly get the BSoD on start-up (can't even boot from CD). I tested the memory and both the sticks seem to load fine so I'm pretty sure it's the hard drive, I don't see why that should have affected the sound on my TV but when I get my new harddrive and re-install windows I'll try it again and see if it makes a difference
!