Sign in with
Sign up | Sign in
Your question

System won't boot after new CPU Cooler

Last response: in Systems
Share
September 17, 2012 5:12:57 PM

Hi.
Last christmas i built my own PC. It worked absolutely fine. I recently tried to replace the stock CPU Cooler with a Corsair h80. Now my PC won't boot. As in at all. The LEDS on the Mobo are lit up (no error LEDS) but when i press the power button nothing happens. The fans don't spin and then stop. It just doesn't do anything. I have checked that the power switch is plugged into the mobo. Please help if you can - thanks in advance :bounce: 

System specs:
CPU: 2500k (not overclocked)
RAM: 2x 4gb of Corsair Vengeance
CPU Cooler: Corsair H80
Mobo: ASUS P8z68-v LX
HDD: Seagate 2TB Barracuda Green
GPU: ASUS 560ti
PSU: 500W Coolermaster

More about : system boot cpu cooler

a b B Homebuilt system
September 17, 2012 5:32:11 PM

You can use ANY CPU cooler you want, its only a piece of copper with fans, it has nothing to do with your system malfunctioning.

The first time i tried to replace the stock HS of my PC i burnt the motherboard with static electricity, i am sure that that's what happened, you burnt your motherboard.
September 17, 2012 5:38:24 PM

OK, thanks. Is it normal that the LED's on my mobo are still working if it is burnt?
Related resources
a b B Homebuilt system
September 17, 2012 5:42:18 PM

nathansam said:
OK, thanks. Is it normal that the LED's on my mobo are still working if it is burnt?


Your whole motherboard isn't burned. i bet that if you take the frame surrounding the CPU socket you will see a burn sport.
September 17, 2012 5:45:46 PM

Is my CPU ruined then?
a b B Homebuilt system
September 17, 2012 6:04:09 PM

nathansam said:
Is my CPU ruined then?


i doubt it, do you have any other CPU you could use?
September 17, 2012 6:44:34 PM

My PC is working, I hadn't put the case back together properly :lol: 
It's all working fine now. Thanks for all the help droid
!