Sign in with
Sign up | Sign in
Your question

No LAN Network

Tags:
  • LAN
  • Networking
Last response: in Networking
Share
September 16, 2011 4:36:19 PM

I am running Vista Home Basic with SP1 on a 32 bit PC.

Whenever I try to go online using a good ethernet cable to my modem (I know both of them are good because THIS PC is using the same cable and modem) I get the 'Internet Explorer cannot display the webpage' msg.

If I then click on Diagnose Connection Problems I get the msg Network Diagnostics cannot run because the Diagnostics Policy Service is not running. If I go to Services.msc, and attempt to start the service I get Error 5: Access is denied. There are no dependencies on this service.

If I hover the mouse over the network icon in the notification area, it reads, "Connection status unknown. The dependency service or group failed to start".
If I try to start DHCP Client, I again get Access denied..

I ran a full Malwarebytes scan and it found nothing wrong.

I did a system restore to several days before the problem, but even though the restore completed successfully, it didn't change my (non)results.

I have run sfc /scannow as well as chkdsk /f. Scannow reported that it found some problems but was unable to fix all of them. The CBS.log is not something I'm able to interpret. I have run chkdsk /f about 6 times, sometimes in safe mode, sometimes normal. It always seems to find and correct the same 10 or so errors. Neither chkdsk or scannow helped with the connectivity issue.

The Network and Sharing Center does not display the familiar PC monitor icon with a line to the Network and another line going from the Network to the Internet. Instead it just has the word Unknown with the caption the depencency or groiup failed to start

I have heard that this might be due to a permissions issue. So I used regedit and navigated to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services and right click on Dhcp. I don't have Permissions available. I mean I don't even have the WORD Permissions

I gone run msinfo32 and verified that I am not suffering from Winsock2 corruption, but I have run netsh winsock reset just the same. And then rebooted. Nothing. I have tried ipconfig /release (and /renew), but with both commands I get the msg that the RPC Server is unavilable. However, in Services, the Remote Procedure Call is Started
I have checked device manager. No red or yellow areas. Network adapter and driver functioning correctly.

Additionally I have downloaded and installed Process Monitor on the PC, but the amount of information displayed is overwhelming, and I'm not sure what to check. Every time I try to start DHCP I get about 200 lines of info on the screen.

When I open a command prompt and run ipconfig /all, I get the bogus ip address of 169.254.xxx.xx and a Default Gateway of 0.0.0.0.

This was working just fine last week. I hadn't shut it off for days. Then I shut it off. It hasn't worked since.

Do I have to reinstall Vista because of a service issue? How could it have gotten so corrupted?

More about : lan network

September 18, 2011 1:57:50 AM

it sounds like your group policy settings are jacked. you should be able to access your group policy settings on any admin account that has not been revoked in group policies. if yours has then you can restart in safe mode after activating your hidden admin account through the cmd prompt. group policy restrictions is a common thing for viri to change
m
0
l
September 18, 2011 4:25:40 AM

gpedit.msc is not a command I can run on this PC. And AIAS I could not make any permission changes through the registry.

I did stumble on these two little commands, run as an Administrator that did the trick:

net localgroup administrators localservice /add
net localgroup administrators networkservice /add

It's just sort of sad that absolutely nobody, in any of the several forums I posted to, knew this. Or if they did know it, they didn't post.

And while I thank you for your reply, re-reading it does point out a real lack of actual instruction.

Phrases like 'you should be able to access your group policy settings on any admin account that has not been revoked in group policies' and 'restart in safe mode after activating your hidden admin account through the cmd prompt' while no doubt full of meaning to the computer professional, mean absolutely nothing to me and my machine.

Something like first do this, followed by an easy to follow set of instructions might've not only assisted me, but could also have helped others browsing this forum.

But thanks again for the reply.
m
0
l
September 19, 2011 4:22:32 AM

my intent was simply to direct you towards where the issue was in your OS. not to list a step by step instruction set for what may solve your issue. Google is a good friend in that respect. doing back door edits through cmd are great ways to go around the problem of not being able to load a built in windows mgmt service such as gpedit but this is not what i start with when giving advice as most people prefer GUI's. im glad you got your problum fixed but do understand that its difficult to provide spot on support over a txt based format. i believe i speak for most techs when i say we prefer to be at the computer or at least remotely logged in to do the repairs our selves. this is not to say the user is not able to do a repair but often i find myself bouncing between many different tools or different paths to achieve the same goal. to list all the available options to solve an issue would take a much longer segment of time on this forums and inevitably be redundant in the information it provides.
m
0
l
September 19, 2011 7:15:45 AM

ncc74656 said:
my intent was simply to direct you towards where the issue was in your OS. not to list a step by step instruction set for what may solve your issue.

Yeah, I get your intent, but as I already said, your previous post was useless to me because you didn't TELL me how to access my group policy settings, or how to activate my hidden admin account. Simply telling me that 'accessing and activating' are the path to a solution is only helpful when your sentences mean something to me.
m
0
l
September 29, 2011 12:29:05 AM

Two little commands, run as an administrator

net localgroup administrators localservice /add
net localgroup administrators networkservice /add

Took a lot of work, and a lot of searching, a lot of trial and error, but I finally stumbled on these commands. Exactly the kind of help I would have expected from a forum like this. Sigh...
m
0
l
September 29, 2011 1:02:51 AM

-----Original Message-----
From: Tom's Hardware <forums@tomshardware.com>
To: mobo2527500792 <mobo2527500792@aol.com>
Sent: Wed, Sep 28, 2011 7:55 pm
Subject: Did you get your answer? "No LAN Network"

Hello ,
we noticed that your thread is not active anymore. Did you get the answer that
you were seeking? We invite you to review the answers, and select the best one
as your "Best Answer" (click on the gold cup above it).
Click here to review the answers to your question: http://www.tomshardware.com/forum//forum2.php?config=to...
Selecting a "Best Answer" will help the community to easily spot answers to
similar issues or questions.
If you did not get the answer you were seeking, we suggest that you add details
to your question. By doing so, you will get renewed attention to your issue.
Thank you for contributing the Tom's Hardware community
The Tom's Hardware community team
*************

My own final reply to the thread is the best answer. Since it's my answer I'm unable to select it as the best answer.

Maybe someone else could do that.

m
0
l
!