Sign in with
Sign up | Sign in
Your question

Browsing problem. Pc to laptop to wireless router to internet.

Last response: in Networking
Share
September 16, 2011 6:46:15 PM

Hello!

My problem is that my browser on my pc randomly losses internet connection, but steam, skype etc. keeps working so it's not a total loss of connection.

My LAN looks like this.
Pc is connected to my laptop with a crossover cabel. Laptop then is connected to a router with wireless. And router to the internet.
I've bridged the connection between my network adapters on my laptop to share internet with my pc.
My pc has got IPv4 settings on automatic while i got my laptop IPv4 settings fixed.(not same ip range as the wireless)
My quickfix to this problem is to disable/enable my network card on my pc. In otherwords reseting the adapter.
But it's really starting to annoy me. I belive the problem lies between the pc and the laptop.
I would be greatful for any ideas to solve this problem.

Thanks

/ZeuS
September 18, 2011 2:54:12 AM

this is a DNS issue. check what your default DNS servers address is, make sure its going to the correct server. I have this issue as well but its a comcast issue here. i installed my own DNS server on a cisco switch i have to replace the comcast dns when it cuts out.
September 20, 2011 10:22:19 PM

Thx for the help, sry i forgott i had a tread here :p 
I'm a bit noob when it comes to DNS.
But isn't DNS a system that transforms ip addresses to names and the other way around?
The thing is that there are also other people connected to the router and they don't seem to have this problem.
So i don't think it has something to do with the internet connection.
And we don't use dns names in our local network.
Related resources
September 20, 2011 10:42:36 PM

ok, well if they can see websites and you can not then its an issue with your computer. its possible that your computers dns service is having issues. try this, go to the command line, run and cmd. type ipconfig /flushdns. make sure your dns service is started and set to automatic. access your services by going to run and typing services.msc and scrolling down. if all that fails try setting your dns ip address manually. the dns should be the same as your router's ip as that should be forwarding dns requests. you can set this ip to the actual ip address for your isp's dns servers or use another such as google's. google's dns service is 8.8.8.8 and 8.8.8.4. to set extra dns servers with in a dynamic ip address scheme go to your lan adapters properties and double click on tcp/ipv4 config. click on advanced at the bottom right and go to dns tab. in there add dns servers in the order you wish them to be checked.

yes you are correct that DNS links your www html address with its layer 3 ip address.
September 21, 2011 7:04:41 AM

Thank you again for the help :) 

I will try this the next time the computer starts to screw me over :p 

Wierdly it has been working fine now for the past 2 days.
!