Sign in with
Sign up | Sign in
Your question

Far Cry 3 None CPU Usage

Tags:
Last response: in CPUs
Share
February 3, 2013 12:45:14 PM

Hello, i have a problem when I am playing Far Cry 3 at max resolution, (1920x1080 Ultra) I only get 10-15fps.
When i set the resolution to the lowes ( 800x600 and Low settings) I get30-40 Fps.
Here are my PC specs:

Processor: Intel® Core i7-2600K Quad-Core OCed to 4.2Ghz
Graphic cards: Dual XFX Radeon HD 7970 in CrossfireX Mode with 6GB GDDR5 Video Memory
RAM: Kingston DDR3 HyperX 1600MHz 16GB
Mother board: MSI Z68A-GD65 (Gen3)
Power supply: Corsair TX V2 850W PSU
Hard disk: OCZ SSD 240GB REVO3 PCI-E 1000Mb/s Read 900Mb/s Write

When i look at the Task Manager it says CPU usage 3-8% and Far Cry 3 only uses 150-200 Mb of RAM.
GPU1 is laying at 99% and GPU2 at 40-60%.

When I play battlefield 3 at max ( 6000x1080 Eyefinity Ultra ) I get between 50-70 Fps and the CPU is laying at 80-95% and uses 2000-2500 Mb of RAM.

I haven't seen anybody else have this problem, any ideas?

More about : cry cpu usage

a b à CPUs
February 3, 2013 3:56:15 PM

are you using the latest driver?

think there was a release that improved far cry 3 performance

i played it on a 2600k at 5ghz and a single 7970 no problem

and just to say 2x 7970 3gb doesnt give you 6gb of graphics memory its still only 3gb
a b à CPUs
February 3, 2013 4:31:05 PM

If you disable crossfire using only one GPU, then I'm sure the problem will be solved. Not every game is optimized for crossfire. I assume you're using the latest drivers when you got such a sweet setup, if not then you can possibly fix it by getting the latest.
Related resources
Can't find your answer ? Ask !
February 3, 2013 6:55:15 PM

I have all the latest drivers, sorry I forgot to add that...

I disabled Crossfire and it runs like butter with 80fps on ultra!!

Thank you both very much for the feedback :D 
a b à CPUs
February 3, 2013 7:10:38 PM

you may need to update the game to utilize CF/SLI or they simply don't want to release a patch for it. glad it all worked out with a single card
!