HELP: AMD A4-3400 Llano - no video / black screen w/driver update

Trying to put together a cheap simple little system, BUT having video problems...

System is as follows:
CPU - AMD A4-3400 Llano 2.7GHz Socket FM1 APU
http://www.newegg.com/Product/Product.aspx?Item=N82E16819106014
MB - MSI A55M-P33 FM1 AMD A55 (Hudson D2) Micro ATX AMD Motherboard with UEFI BIOS
http://www.newegg.com/Product/Product.aspx?Item=N82E16813130641
RAM - Corsair 4GB 1600 MHz
PS - Corsair 430w
DVD - LG
HD - Western Digital 120 GB 2.5" 5400 rpm

Installed:
(this is the 3rd attempt for windows 7, before I didn't do all the updates and was hoping that might have caused a problem)
1) Windows 7 then WIN 7 SP1
2) ethernet driver (from CD)
3) then download all windows updates (like 30 restarts later)
4) installed chipset drivers (from CD, restart)
5) right click update display adapter, let it download automatically
--> on restart BLACK SCREEN, shows the windows logo "starting windows", you can see it turn blue with the welcome then it turns to BLACK screen and there is no image.
This will also happen if you install AMD catalyst Suite 12.8.

Everything will run until you update the graphics driver to recognize the 6410D, on restart you get no video signal. Tried connecting both VGA, DVI and DVI to HDMI

It will boot into safe mode, if I uninstall the graphics card driver it will boot back into windows and have signal again. But updating the driver will cause the black screen on restart (or blue screen on DVI to HDMI cable)

Also, tried swapping out the ram for different sticks, tossed in my 700w PS, different vga cable...Seems like its some driver issue...

Any thoughts would be great!
12 answers Last reply
More about help 3400 llano video black screen driver update
  1. Have you tried different display drivers? If not, try and find the newest version. Make sure you get correct one(32 vs 64 bit). You're just using the integrated chip gfx right?
  2. Its the AMD A4-3400 Llano with integrated AMD Radeon HD 6410D

    I tried letting windows automatically update the driver = Black screen
    I tried AMD Catalyst Display Driver, Win 7 64-bit, vr. 12.8 dated 8/15/2012 = Black screen

    The default display driver that loads with windows 7 will work, but its generic so no performance, i.e. windows graphics score = 1.0; right now under device manager it is listed as "other device" "Video Controller (VGA compatible)"
  3. Well sounds like you tried everything I would have. I'm out of ideas.
  4. try an earlier driver. get catalyst 12.6
  5. ScrewySqrl said:
    try an earlier driver. get catalyst 12.6


    Good idea...downloaded, tried 12.6 = black screen
    Tried hooking up to a 24" widescreen and a 17" standard screen

    Back the to basic standard "VGA graphics adapter" and time for some more google research...

    Found a somewhat similar problem...but no resolution (sounds more like the motherboard on this one)
    http://www.tomshardware.com/forum/327915-31-htpc-build-boots-video-output
  6. could be.
  7. Tried AMD Catalyst Display Driver, Win 7 64-bit, vr. 12.1 = black screen

    Just updated to the latest BIOS v1.6 - 08/31/2012
    - Tried AMD Catalyst Display Driver, Win 7 64-bit, vr. 12.8 again, but got the black screen again after restart :cry:
  8. something wrong then. I will suspect something defective in the chip or the motherboard
  9. - Tried resetting BIOS to defaults, still get the black screen
    - Pulled the CPU, used air to blow out the socket, re-seated, still black screen of death

    These are the general drivers I have tried:

    Default generic driver is: (this works)
    Standard VGA Graphics Adapter
    Driver Provider: Microsoft
    Driver Date: 6/21/2006
    Driver Version: 6.1.7600.16385

    Windows Driver with Automatic Update: (=black screen)
    AMD Radeon HD 6410D
    Driver Provider: Advanced Micro Devices, Inc.
    Driver Date: 10/25/2011
    Driver Version: 8.911.0.0

    AMD Catalyst 12.8 Driver: (=black screen)
    AMD Radeon HD 6410D
    Driver Provider: Advanced Micro Devices, Inc.
    Driver Date: 7/27/2012
    Driver Version: 8.982.0.0

    Still seems like a driver problem works "ok" with the 2006, but newer versions cause black screen of death
    Maybe at this point its some kinda of hardware failure?? APU or motherboard?
    Can the CPU/APU fail partially? Can a motherboard failure produce these symptoms?

    Any other ideas?
  10. that 2006 driver is a generic vga driver, very basic.

    the full driver uses the full chip.
  11. ScrewySqrl said:
    that 2006 driver is a generic vga driver, very basic.
    the full driver uses the full chip.


    Yea, at this point I'm thinking my graphics portion of the APU is a dud... :cry:

    - Tried AMD Catalyst Display Driver 11.12 = black screen

    Memtest86+
    - I did find 1 of my corsair sticks is apparently dying after 1.5 yrs of use... (had tested overnight ~1.5yrs ago in my other computer); so pulled that memory tossed in the 8GB that came with this combo deal: G-Skill ARES 1600MHz, ran Memtest86+ overnight 7+ hours no problems. On restart w/updated drivers = black screen of death

    - Runs Prime95 on Blend, ran it for awhile over breakfast

    - Turned on sharing and remote desktop, on restart with updated graphic drivers = black screen and NO connection or sharing available

    Will contact newegg later today and see what they say...
  12. Thanks for all the ideas, believe it or not I finally accidentally fixed it.

    I just got in a new cheap mid tower case today, a cooler master elite 430, the ONLY thing I hadn't swapped out was the case. So it a last ditch effort I moved all the parts over and what do you know it booted and is now running AMD CCC vr. 12.8 :D

    I am still not sure what it was, maybe a power connector wasn't fully seated (although I think they were all checked at least twice), maybe some sort of odd grounding problem with the motherboard. The case was an old recycled dell inspiron 530 I have for testing and it has the dimpled stand offs which are a bit larger than the screw in ones...

    I'm not sure what but everything seems good now so far...knock on wood!

    For under $125 total investment (recycled HD) it seems like a pretty good little machine now that its running.
Ask a new question

Read More

Homebuilt Video AMD Systems Product