Sign in with
Sign up | Sign in
Your question

Trouble putting my new PC together

Last response: in Systems
Share
September 21, 2012 3:32:18 AM

Ive built a computer once before and it was fine but last night i put my new one together and encountered some problems, im not very good with computer internals. but after i got everything plugged in i hooked it up and turned it on and all the fans/ video card fan came on so i assumed it was gonna work but i cant get any kind of picture on my monitor, http://www.newegg.com/Product/Product.aspx?Item=N82E168... is my video card, i have it into the motherboard but one thing i wasnt aware of was the 2 six pin connectors that needed to be plugged into the power supply so those arent in and i dont have anymore cables coming from my supply, can i open it up and put more in? and would that solve it? also the cd drive isnt working i have the sata cable plugged in, am i missing something there? sorry if this is horribly explained idk much of what im talking about :/ 

http://www.newegg.com/Product/Product.aspx?Item=N82E168... power supply btw

More about : trouble putting

a b B Homebuilt system
September 21, 2012 3:52:21 AM

Your psu has a 6-pin and a 6+2-pin pci-e. What are you doing with them or are they still in the box? Your psu is modular did you plug all of the cables in.
m
0
l
September 21, 2012 3:55:35 AM

I have two 6x2 pci-e that were in a bag of cords i just pulled out from the psu box . theres like 5 cords in there, should they all be in? i thought they were just spares
m
0
l
Related resources
a b B Homebuilt system
September 21, 2012 4:09:30 AM

Put in the 2 pci-e. Do you have the cd drive connected to the motherboard and a sata power cable connected to the cd drive from the psu. If no then put in a sata cable too.
m
0
l
September 21, 2012 4:35:16 AM

i plugged in the the pci cables, idk what the sata power cable looks like though, i just have the really small black one going from the cd drive to the motherboard, also i think i have my grahpic card in the wrong slot? in my manual it says mines in x4, should it be the x16?
m
0
l
a b B Homebuilt system
September 21, 2012 4:46:59 AM

zach1301 said:
i plugged in the the pci cables, idk what the sata power cable looks like though, i just have the really small black one going from the cd drive to the motherboard, also i think i have my grahpic card in the wrong slot? in my manual it says mines in x4, should it be the x16?


Yes it should be in the x16 slot. There should be 6 sata power cables that came with that psu. Your hard drive needs one and the cd drive needs one. Google it if you need to know what it looks like.

**edit
Here is what they look like http://en.wikipedia.org/wiki/File:SATA_power_cable.jpg
m
0
l
!