Trouble putting my new PC together

Ive built a computer once before and it was fine but last night i put my new one together and encountered some problems, im not very good with computer internals. but after i got everything plugged in i hooked it up and turned it on and all the fans/ video card fan came on so i assumed it was gonna work but i cant get any kind of picture on my monitor, http://www.newegg.com/Product/Product.aspx?Item=N82E16814150561&nm_mc=AFC-C8Junction&cm_mmc=AFC-C8Junction-_-na-_-na-_-na&AID=10446076&PID=3938566&SID= is my video card, i have it into the motherboard but one thing i wasnt aware of was the 2 six pin connectors that needed to be plugged into the power supply so those arent in and i dont have anymore cables coming from my supply, can i open it up and put more in? and would that solve it? also the cd drive isnt working i have the sata cable plugged in, am i missing something there? sorry if this is horribly explained idk much of what im talking about :/

http://www.newegg.com/Product/Product.aspx?Item=N82E16817151093&nm_mc=AFC-C8Junction&cm_mmc=AFC-C8Junction-_-na-_-na-_-na&AID=10446076&PID=3938566&SID= power supply btw
6 answers Last reply
More about trouble putting together
  1. Your psu has a 6-pin and a 6+2-pin pci-e. What are you doing with them or are they still in the box? Your psu is modular did you plug all of the cables in.
  2. I have two 6x2 pci-e that were in a bag of cords i just pulled out from the psu box . theres like 5 cords in there, should they all be in? i thought they were just spares
  3. Put in the 2 pci-e. Do you have the cd drive connected to the motherboard and a sata power cable connected to the cd drive from the psu. If no then put in a sata cable too.
  4. i plugged in the the pci cables, idk what the sata power cable looks like though, i just have the really small black one going from the cd drive to the motherboard, also i think i have my grahpic card in the wrong slot? in my manual it says mines in x4, should it be the x16?
  5. zach1301 said:
    i plugged in the the pci cables, idk what the sata power cable looks like though, i just have the really small black one going from the cd drive to the motherboard, also i think i have my grahpic card in the wrong slot? in my manual it says mines in x4, should it be the x16?


    Yes it should be in the x16 slot. There should be 6 sata power cables that came with that psu. Your hard drive needs one and the cd drive needs one. Google it if you need to know what it looks like.

    **edit
    Here is what they look like http://en.wikipedia.org/wiki/File:SATA_power_cable.jpg
Ask a new question

Read More

Homebuilt Computer Systems Product