Sign in with
Sign up | Sign in
Your question

No sound devices detected

Last response: in Components
Share
February 4, 2013 6:28:57 AM

Hi, I've run into an issue where no sound devices are detected, aside from those that I'll mention.

I built my computer from scratch (thanks to help/info from tom's) back in May 2012 and it's been pretty smooth. However, I never actually bought a pair of speakers (I know, how could I not) because I had a nice headset (Logitech G35). Anyways, I never really had a sound problem either, because when I plugged in a pair of portable speakers thru the front headphone jack back in August, I had sound. I was able to play some music without any issues and I know the headphone jack showed up in the "playback devices" menu. I should also note that my second monitor (explained at the bottom) had built-in speakers, which worked.

Now, I recently noticed a week ago that plugging anything into either the front or rear audio jacks hasn't worked.

My specs are (and they're in my profile): intel i5-3570k
asrock z77 extreme6
2gb evga gtx 670 stock
corsair vengeance ram (ddr3 1600mhz 2x4gb)
samsung 830 256gb
WD CB 2tb
and the rest I know are okay and/or don't matter.


What currently appears in "playback devices" are as follows:

Speakers (6- logitech g35 headset, default device)
NVIDIA HDMI Output (Port 0), NVIDIA High Definition Audio, Not plugged in
NVIDIA HDMI Output (Port 1), NVIDIA High Definition Audio, Not plugged in
NVIDIA HDMI Output (Port 2), NVIDIA High Definition Audio, Not plugged in
NVIDIA HDMI Output (Port 3), NVIDIA High Definition Audio, Not plugged in


Nothing else appears. I tried reinstalled the latest realtek audio drivers specific to my mobo from asrocks website. It is "7.1 CH HD Audio with Content Protection (Realtek ALC898 Audio Codec), Supports THX TruStudio™ " Incidentally enough, it is the exact same driver as the one I originally installed (And worked) back in May 2012.

What is funny about the nvidia audio devices listed is that there is only 1 HDMI port, so why would it say there are 4 possible ports?

I tried completely uninstalling and removing using CCleaner. Then reinstalling. I just updated my nvidia drivers to the latest stable, then tried latest beta.

I downloaded the latest stable BIOS (2.60) for my mobo.

I also made sure onboard HD Audio was enabled (the rear jacks), and the front audio jacks can only be set to "Auto" or "Disabled".

One other thing I've noticed, is that the Realtek Audio (orange) icon thats supposed to be in my system tray is not there. I think it used to be there, but that was a long time ago and I don't know when it ever disappeared (since I've been using Audio over USB).

I made sure "Realtek High Definition Audio Driver" was actually installed by checking whether or not I could uninstall it (it does appear in Programs and Features). I also just tried running the "RAVCpl64.exe" found in the Vista64 folder in the Realtek Audio driver folder I downloaded. No luck.

Running THXTruStudio, it gives a pop-up message showing nothing is connected in either audio jack.

Checking the mobo itself thru the BIOS, ASRock has this nice interactive mobo that lets you see what's connected to where, and when I click on either audio ports, it shows nothing is connected, even if I've stuck a 3.5mm headphone jack in there (both headphones and speakers).

I did read somewhere briefly that nvidia hd audio drivers tend to cover up all other audio drivers, but I'm not sure why that would've happened, especially if it worked before. I can't find anyway to disable Nvidia HD Audio.

Finally, I have a 2-monitor setup. The main monitor (that I game on) is a Dell U2412M at 1900x1200 and is connected via Display Port. The second monitor (Asus V248H) is connected via DVI-D (as opposed to DVI-I). I used to use the speakers on my second monitor, but stopped when my headset came in because of the difference in sound quality. I used to use an HDMI cable to my 2nd monitor to transmit sound, but the HDMI port on my 2nd monitor broke somehow.

I REALLY don't want to have to buy a sound card.

Any help would be most appreciated. Thanks!

More about : sound devices detected

February 4, 2013 9:48:05 AM

I should also add that everytime I install Realtek HD Audio, it says it stalls and then requires I restart my comp, so I do. Once I get back on, I check and there is no tray icon. Also, in Device Manager, Realtek HD Audio or anything with Realtek does not show up under "Sound, video, and game controllers." It's like it disappears right after it's installed. This goes for the Realtek HD Audio driver 2.70 from the realtek website and the audio driver from asrock's website.

However, when I go to control panel -> Uninstall a Program, I see Realtek High Definition Audio Driver is installed.

The things listed under "sound, video, and game controllers" are:
Intel(R) Display Audio
Logitech G35 Headset
NVIDIA High Definition Audio
m
0
l
!