Sign in with
Sign up | Sign in
Your question
Solved

AC: Revelations strangely laggy

Last response: in Graphics & Displays
Share
August 2, 2012 7:33:04 PM

Hello,
8GB Ram, one of those i7-2670 processors, 2.2GHz (8 CPU's), and a GeForce GTX 560M graphics card. Game lags ... like crazy. No lag in any other title I own, some like Crysis 2, Skyrim, or MW3 should be more demanding, right? And I really mean "lags," like, nearly unplayable lags. So, I contacted Ubisoft, and they said that the laptop version of the grahpics card isn't supported. Solutions, beyond getting a new card?
a b U Graphics card
August 2, 2012 8:00:32 PM

Can you go into more detail about the lags? A low framerate in general usually means a problem with the GPU and/or drivers, while a smooth framerate mixed with pauses of more than 1/2 a second or so means the game is trying to constantly load stuff from the hard drive, or your RAM is full and the OS is relying on the swap file.
m
0
l
a b U Graphics card
August 2, 2012 8:10:55 PM

reply from ubisoft doesn't make sense however even nvidia 7300gs are supported which are too older cards. Like you said that there is no lag in other games so i don't think that will be the driver issue just uninstall the game then re-install.
m
0
l
Related resources
August 3, 2012 12:13:22 AM

Uninstalling and reinstalling hasn't worked; it's a sporadic but often occurence ... this lag. Interestingly, it occurs even on startup with the Ubisoft logo and the menus. It's been downloaded through Steam, although I'm not sure if that matters.
m
0
l
a c 291 U Graphics card
August 3, 2012 12:36:30 AM

I had that too with my GTX 560 Ti! I managed to find the solution though: force adaptive vsync through the nvidia control panel. Hope it helps for you :) .
m
0
l

Best solution

a c 291 U Graphics card
August 3, 2012 11:04:19 AM

Open up nvidia control panel, click on Manage 3D Settings, click on global tab, scroll down to the very end and under vertical sync select "Adaptive'.
Share
a b U Graphics card
August 3, 2012 5:01:12 PM

I had character lag with Assassins' Creed Revelations. I fixed it by removing a file from the install directory. I don't remember the file exactly..
m
0
l
August 3, 2012 9:43:30 PM

Awesome. It worked. Two things though: will keeping this setting affect other games, and how do I mark this thread's question as resolved ... juist by changing the title?
m
0
l
a c 291 U Graphics card
August 3, 2012 9:48:44 PM

1. Yes, it will, because you changed global setting. However, I would not worry about it, because Adaptive VSync does nothing bad but fixes those hiccups when fps drops suddenly. I have it enabled as global setting too ;) .

2. To mark it as solved, select the best answer.
m
0
l
August 3, 2012 11:29:49 PM

Best answer selected by Afinati.
m
0
l
a c 291 U Graphics card
August 3, 2012 11:30:36 PM

Glad I managed to help you :) .
m
0
l
!