Newly built system...no display after working perfectly for 24 hours.

Hey guys,

Just finished building my new rig, and now it seems to have crapped out on me. Here are the specs:

Intel i5 3750k
MSI- Z77 ga45 mobo
Ultra 650w ps

I'm running it on the on-board intel hd4000 graphics gpu for now until I get my 660ti in the mail.
I installed all components according to manufacturer instructions, and it booted and worked perfectly for 24hrs. I was able to install windows and install and play a few games of League of Legends. I had a problem while I was running the game where the computer locked up and had to be restarted. So I installed all windows updates, and installed all the latest drivers. It worked perfectly after that, no freezes or resets. I left it over night, and went to turn it on this morning and nothing happened. The mobo lights turned on for a brief second, but no fans. I cracked it open and checked all the plugs on the mobo and found the 24-pin was a little loose, so I tightened it up. After that, all of the fans turn on, and the mobo lights up and appears to be running. No beeps (im a little worried about the system speaker status because I have never heard it beep even when the rig was working). The display fails to turn on (monitor says no connection). So I'm not sure if I am having some kind of compatibility issue with the on-board graphics card or if I fried my mobo.

I went through the checklist here:
http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems

and did everything that didn't require disassembly. I'm hoping this will be something that I can fix without tearing this thing apart.


Please help!
5 answers Last reply
More about newly built system display working perfectly hours
  1. You could try unplugging the PSU, pushing and holding down the power button for about ten seconds to remove any residual power, and removing the CMOS battery to do a full reset of it. Re-seat it and plug the computer's power cord back in and try booting. You could also try disconnecting all connectors, cleaning them (moisture-free compressed air canisters can work great), and reconnecting them. It often works for me when I have similar problems.
  2. I unplugged everything, then cleaned with compressed air. I reset the cmos by taking out the battery for the duration. I have put it all back together and it is doing the same thing. The led lights on the inside above the cpu are now blinking, as well as the leds on my mouse and keyboard
  3. Bump. I really need some help. Or suggestions on a new mobo
  4. The ASRock Pro3 is a good basic Z77 board and the ASRock Extreme 4 is an excellent band for your buck enthusiast board.
    http://pcpartpicker.com/part/asrock-motherboard-z77pro3
    http://pcpartpicker.com/part/asrock-motherboard-z77extreme4
  5. Most probably PSU issue.
Ask a new question

Read More

Homebuilt Systems Product