ATI slow in crysis 2

I am using HD 7870 , why I am play crysis 2 the game running slow .
all setting is ultra , dx11 on and high res tex
any body tell me how to fix it

i7 3770
16 1600mhz ram
resolution 1440 x 900
6 answers Last reply
More about slow crysis
  1. at that resolution, it should be extremely easy for the 7870 to run crysis. Is crysis the only game having this problem?
  2. trying updating your video drivers and motherboard drivers
    and it may sound weird but also update your sound drivers which sometimes cause poor perfromance in some games for some reason...
  3. also play metro 2033 in very high ,dx11 ,advance dof on, tellsat on,no physx , no mass, also getting slow.
    but i dont know why battlefield 3 running fast in all graphic at ultra setting

    my ati driver is 12.7 beta

    i heard some people said crysis 2 getting slow is vsync on
    or is that nvidia physx problem
  4. Turn V SYNC off, when the frame rate dips below 60 fps on a 60HZ monitor v sync will force the frame rate to 30.
  5. Hey I have the same config. I use a 2600K with a 7870. Yes, the high texture pack is causing issue with my rig also. I just don't get it.
  6. http://www.behardware.com/articles/838-4/crysis-2-dx11-a-closer-look-at-performance-and-tessellation.html
    With that settings you should be getting around 30-40 fps.Lower your settings to extreme and you'll be fine
Ask a new question

Read More

Radeon Crysis ATI Graphics