Sign in with
Sign up | Sign in
Your question

Drivers aren't updating past 11.9

Last response: in Graphics & Displays
Share
August 3, 2012 8:16:23 PM

Hi all, hoping you can help.

I have an AMD HD5800 series card (I believe it's a 5860), and no matter what I try, the drivers will never update past 11.9. The auto-downloader in Catalyst manager says I have the latest version, and when I manually download and run the 12.4 installer, it just updates to 11.9.

I have tried removing all drivers and installing from scratch in safe mode, but the same issue occurs.

I've also scoured google, but it's hard to find anything relevant to my issue. If anyone has any ideas, I would be most grateful!

Regards,

Alex

More about : drivers updating past

a b \ Driver
August 4, 2012 2:32:08 AM

Have you tried running driver sweeper in safe mode after uninstalling the existing driver in normal mode? If not, uninstall the driver, boot to safe mode, run DS and have it remove any AMD/ATI and Nvidia graphic driver remnants it finds. Re-boot and install the latest driver.
http://phyxion.net/Downloads/

Don't fall for the ad in the red box.
August 4, 2012 2:39:57 AM

sometimes the version number doesnt physically change in the registry and is stuck. but in reality, it can be updated without changing the name. thats what happened to me with 12.3 when i updated to 12.7
Related resources
August 4, 2012 2:41:01 AM

+1 clutchc

I had this exact same problem on my Laptop. I did as clutchc said and it then allowed me to install the 12.4 drivers with no issues.
August 4, 2012 10:17:27 AM

I haven't - sounds like a good plan. Will give it a shot later today!
August 20, 2012 4:23:46 PM

Hey guys, unfortunately I tried as clutchc suggested, and it's still only at 11.9 - is there anything else you could suggest?
August 20, 2012 4:30:08 PM

It won't let me edit my previous reply for some reason, so here's a link to a screenshot of my Catalyst Control Centre's software screen if that helps:

http://imgur.com/ciPYN

I'm pretty sure at some point when the drivers were showing correctly that instead of 'Click here for system information' it actually showed details of my card, but I might be mis-remembering.
August 20, 2012 5:12:44 PM

Update to the Newest version(now 12.8). For some reason the Beta version does not update the Catalyst Version Number. However, the Driver Packaging Version, 2D Driver Version, Direct3D Version and OpenGL Version are all updated. I did a check on this the last time I installed Windows and verified that the Drivers were all updated by checking all the version numbers and the only one that wasn't getting changed was the Catalyst Version Number. Version 12.8 fixed that too. I suspect that there was an oversight on the part of the programmers at AMD when they released the 12.7 Beta driver. It's nothing to worry about.
August 20, 2012 8:40:01 PM

Thanks for the response JKatwypoc, though I did download the 12.8 drivers to update to. I'm not massively technical but I wouldn't use an old bunch of drivers I had kicking around to update with, hah :) 
August 20, 2012 9:31:51 PM

I didn't think you would. Just relating my experience. When you install windows, it automatically starts updating windows and one of those updates is the display driver. The latest version that comes from Windows update is 11.9. That's probably why yours was stuck on 11.9. I had installed up to version 12.3 before atempting to install the beta 12.7, so mine was stuck on 12.3 for a while.
August 22, 2012 3:11:30 PM

I had the same problem!!! The drivers get updated but the number (11.9) dosent get changed. You have to go into the registery and change the catalyst version manually. Ill go and check how to do it and post back later. Thats what i did and it worked
August 27, 2012 1:50:32 PM

2rock7 said:
I had the same problem!!! The drivers get updated but the number (11.9) dosent get changed. You have to go into the registery and change the catalyst version manually. Ill go and check how to do it and post back later. Thats what i did and it worked


Ahh right, interesting... yeah if you could let me know how you did that, that would be great! :D 
August 27, 2012 3:14:57 PM

OK this is what you have to do:
First go in the start menu, the in the search bar search this : "Regedit"

click it it and it should ask permission to open it, click yes and proceed.

You should come up with a menu which has these things in the left corner:
Hkey_classes_root
Hkey_current_user
Hkey_local_machine
Hkey_users
Hkey_current_config
open up: Hkey_local_machine
Now follow this path and you should not go wrong.

HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/control/class/
{4D36E968-E325-11CE-BFC1-08002BE10318}/0000

After you click 0000 there should be lots of files on the side. find Catalyst_Version.
double click it and you can change the version of catalyst to anything you want.
preferably 12.8 or you be stupid and change it to something like 200.1111

lol i hope that helped :)  :D 





August 27, 2012 5:31:47 PM

If you install the latest version (12.8) it updates the catalyst version number correctly.
August 27, 2012 11:13:51 PM

well i just updated to 12.8 but the drivers updated but the number didnt change..
!