Closed Solved

Driver(?) problems with crossfire 7970s

Hey people I just got a second 7970 and installed it today and I have been having some really weird problems. I am on 12.7 beta all crossfire cables are hooked up correctly and all that. When I turn on my pc it works fine I can adjust manual fan speed and overclock thru catalyst but when I open GPU-Z it takes several minutes to open and it extremely laggy. The second card has really weird readouts like it says 32-bit memory, only has half the readouts in sensors and none of them work at all. RPM goes between 660 and -- when the fan is actually spinning just normal speed I can see it. the voltages go all over the place as well as frequencies in a very unnatural laggy way. then i close gpu z and go to catalyst and i have no control over the second card and all the sensors in cataylst read 0. also if i boot and dont open gpu z at all then play a game and come back to catalyst i will have lost control and readouts again. it also freezes the whole pc occasionally making me have to reboot

both cards are HIS IceQ X2 same exact cards I have switching them around and running them both single so I know they both work fine. no matter what the configuration of two cards the same errors happen as i wrote above. I also tried switching between the second bios chip and the first on both cards which did not make any difference.

i thought i would also mention that in game it works perfectly fine, crossfire works fans work everything works i get about 100-110 fps in bf3 avg

PSU- ABS Majesty 1100 Watt Gold Certified
MoBo- ASUS P8Z77-V
CPU- Intel Core i7 3770
RAM- 16gb 1600MHz G.SKILL Ripjaws
OS- Windows 7 64

thanks for any advice i am a bit stumped on this one
9 answers Last reply Best Answer
More about driver problems crossfire 7970s
  1. yeah i have heard of times when gpuz in crossfire has given false readings. gpuz isnt perfect. I mean i myself have a slightly false gpuz reading as it says im running pci-e 3.0 using a i3-2120, which only supports up to 2.1
  2. Test each card individually and report back, if necessary switch to CCC 12.3 the most stable CCC.
  3. it is not like its false readings though, i have seen false readings before its like completely laggy it takes about 10 seconds to load the sensors when i switch cards and the reading all go between 0 or -- and random numbers just huge triangles
    usually followed by crashing or flashing black screens

    btw it also ULPS active next to crossfire enabled (2 gpus) eventhough i tried disabling it to fix this
  4. I don't know about GPU-Z but in Catalyst my second 7970 doesn't show any stats as well.
  5. ilysaml said:
    Test each card individually and report back, if necessary switch to CCC 12.3 the most stable CCC.


    tried each individually both work fine but problem is actually a bit different than i thought. everything i listed at first is still happening but ONLY when crossfire is enabled .

    when i enable it the second card (no matter which physical card) shuts off completely and completely glitches out gpu z and ccc, neither fan spins at all (cards have two fans each) and when i disable crossfire it is perfectly normal, full control full readouts all fans spinning normally both cards working normally

    EDIT: second card sits at 500/1375 clock speeds (mid) with cf disabled while first is at 300/150 (low)
  6. Wait I just figured it out. The second card was going into Ultra Low Power Savings and I had to disable that in registries. I thought I had disabled it already but it turned out I had only disabled it on an old registry entry for an old card. I feel like an idiot :)

    Thanks any way though guys
  7. Best answer
    Glad you figured it out. I also was thinking why it worked fine for gaming this explains the state of load.
  8. Best answer selected by iyzik.
  9. This topic has been closed by Mousemonkey
Ask a new question

Read More

Graphics Cards Crossfire Graphics