Sign in with
Sign up | Sign in
Your question

Frame rate issues in BF3 with GTX 680 sli

Tags:
  • Graphics Cards
  • Battlefield
  • SLI
  • Graphics
Last response: in Graphics & Displays
Share
August 4, 2012 12:28:37 AM

Okay i am having a very frustrating problem. I just installed my second 680 to use in sli and was pretty stoked to play BF3 on it. Then i load up the multiplayer and start playing and i am getting massive frame rate drops about every minute. Occasionally it will drop to 45 from 60 with v sync on. Then i turned off v sync and it dropped from 155 to 35. Then on one occasion it dropped to 2 fps and basically froze for a second. I am running a intel i7 3770k oc'd to 4.3 with 16 gb of corsair vengeance ram and a corsair hx 1050 psu. There is no reason i should be experiencing these issues. I have read of other peoples problems with SLI, is there any way to fix this? Thanks in advanced.

More about : frame rate issues bf3 gtx 680 sli

a b U Graphics card
August 4, 2012 12:41:20 AM

are you facing same issues with other games also?
m
0
l
a c 143 U Graphics card
August 4, 2012 12:46:36 AM

Hello & Welcome.
- See if you're getting the same results when running at Singleplayer mode.
- Check that your drivers are up to date.
- Disable HTT in BIOS and see if this helps a bit.
- Try using adaptive V-Sync in nVidia control Panel.
- Look at this thread and try to do the config file trick.
http://forums.overclockers.co.uk/showthread.php?t=18394...
m
0
l
Related resources
August 4, 2012 12:56:01 AM

No, I tested BF3 single player with the same settings and didn't have a single frame rate drop. Then i ran the witcher 2 on ultra and ran between 55 fps and 45 fps consistant. And Skyrim ultra with graphic mods ran at a cosistent 60 fps.
m
0
l
August 4, 2012 1:00:41 AM

ilysaml said:
Hello & Welcome.
- See if you're getting the same results when running at Singleplayer mode.
- Check that your drivers are up to date.
- Disable HTT in BIOS and see if this helps a bit.
- Try using adaptive V-Sync in nVidia control Panel.
- Look at this thread and try to do the config file trick.
http://forums.overclockers.co.uk/showthread.php?t=18394...

I downloaded the latest drivers earlier and tried with v sync on and v sync off and still got massive drops. I thought it could be my SLI bridge but im not having any problems in other games. I will try the HTT disable. and see what happens. Thanks.
m
0
l
a c 143 U Graphics card
August 4, 2012 1:03:41 AM

What's your monitor resolution? A single GTX 680 should maintain you at a constant of 60 FPS in all of the games you mentioned. Try disabling SLI through the panel and see what happens.

m
0
l
August 4, 2012 1:17:20 AM

ilysaml said:
What's your monitor resolution? A single GTX 680 should maintain you at a constant of 60 FPS in all of the games you mentioned. Try disabling SLI through the panel and see what happens.

My monitor resolution is 1920x1080. I originally had the single 680 installed and everything ran fine. It is now doing it with sli disabled as well.
m
0
l
August 4, 2012 1:23:19 AM

I installed MSI afterburner after i added my second 680, that is the only thing that has changed with my system, so i am going to uninstall and see if i still have the problem.
m
0
l
a c 143 U Graphics card
August 4, 2012 1:25:33 AM

Before you do, check that both GPUs are hitting 99% Load.
m
0
l
August 4, 2012 1:27:16 AM

Both Gpus were not hitting 99% load they were sitting around 40-60%. The same problemed occurred without Afterburner installed. I'm not sure why the problem would still be happening with SLI disabled because the single card ran fine for me before. I am going to re seat both cards and disconnect and reconnect them to my psu.
m
0
l
a c 143 U Graphics card
August 4, 2012 1:40:06 AM

Also, update to the latest 304.79 drivers.
m
0
l
August 4, 2012 2:03:35 AM

ilysaml said:
Also, update to the latest 304.79 drivers.

I think i fixed the problem i re seated the cards and attached the power supply and it is working flawlessly. I switched the orientation of the cards and i think once of the pci-e power cords was not all the way plugged in causing the problem. Thanks for all the help :) 
m
0
l
!