Sign in with
Sign up | Sign in
Your question

GTX 670 ftw w/ AsRock z77 extreme 4 problems (Battlfield 3 stutter)

Last response: in Graphics & Displays
Share
August 4, 2012 1:50:07 AM

Hi guys, something weird is going on all my games including battlefield 3 are experience stutter. I've run fraps, I'm getting extremely HIGH fps around 200-300 which isnt normal and then it suddenly drops to like 10-20. The game tries to run, then FPS drops very low, i'm also getting lines like vsync is not enabled. Something is wrong.


It started when I tried to update "Virtua MVP" from the AsRock website thats when all the problem started. I've tried uninstalling it, re-installing the one that came with my mobo CD, nothing works. I've reinstalled display drivers, done clean installs... not working. Maybe my integrated card is enabled by default?



Also, I noticed my NVIDIA control panel has defaulted to slower settings, here is the screenshot

http://i.imgur.com/QEChb.jpg
August 4, 2012 1:55:48 AM

Yea thats what I was thinking, try disabling intergrated graphics in the BIOS
m
0
l
a b Î Nvidia
August 4, 2012 3:03:10 AM

@paddys09 there's no such setting on the motherboard.

@OP: I'd reinstall windows, that Virtu MVP thing seriously messed up your system files. I know this might sound extreme, but it's the fastest fix and it's guaranteed to work.
m
0
l
Related resources
August 4, 2012 3:42:44 AM

Sunius said:
@paddys09 there's no such setting on the motherboard.

@OP: I'd reinstall windows, that Virtu MVP thing seriously messed up your system files. I know this might sound extreme, but it's the fastest fix and it's guaranteed to work.


Reinstalled windows. Something is STILL wrong. I just reinstalled all my drivers off the mobo CD like I did initially.

I also installed NVIDIA drivers off the CD and updated from the web

Now, some windows have blurry text like Chrome, all I did was increase the DPI, text is fine in Windows but it's hazy in Chrome.


My in-game problems still persist. Battlefield 3 is set to Auto, but the settings are showing lower specs than my rig can handle, I dont know whats going on
m
0
l
a b Î Nvidia
August 4, 2012 5:56:55 AM

Are you connecting the monitor to the graphics card and not the motherboard?
m
0
l
!