Sign in with
Sign up | Sign in
Your question

Corrupt downloads using FIOS MoCA adapter

Last response: in Networking
Share
September 20, 2011 6:28:46 PM

Hi All,

I have an odd issue with my FIOS network setup.

I had the 35/35 package installed and have had no issues since installation 2 months ago. I have the Actiontec MI424WR router installed in my basement with RJ45 connections to a WHS 2011 box, a PS3, an XBOX 360, and a TiVo. In my home office upstairs, I have a Netgear WNDR3700 connected to the FIOS network via an Actiontec ECB2200 Ethernet over Coax adapter. I have a few servers/desktops connected via RJ45 to the Netgear router. All machines report speeds over 40mb/s in speedtest.net, with no data issues whatsoever. I can see the devices connected to the Actiontec router in the basement and transfer files between machines without error.

A week ago, I noticed while trying to download a 60mb firmware package (.zip) from www.sharpusa.com, the download would complete but when I went to open the compressed file, I would get a CRC error in the zip file. This could be duplicated - every time I downloaded any large file, I get the same issue (.rar, .zip, self extracting .exe, etc.). I tried downloaded firefox (13MB file), and had the same results.

I went through the following and still had the errors:
-disabled all antivirus
-upgraded motherboard bios
-upgraded motherboard SATA drivers
-lowered DRAM memory speed
-upgraded drivers for onboard gigabyte Realtek LAN
-changed LAN card settings from auto/auto to 1GB/full
-changed LAN card settings from 1GB/full to 100/full
-loaded motherboard "safe defaults"

I then tried on my other office PC (connected to the Netgear router)- same issue.

I swapped out my Netgear WNDR3700 with a spare Dlink DIR-655 I had - same issue.

Removed router from the equation, and plugged MoCA adapter into PC directly, same issue.


I then took an IBM laptop, and connected wirelessly to the Dlink and Netgear router in the home office - able to duplicate issue. I then switched wireless connection to the Actiontek router in the basement and * didn't * have the issue.

I installed the Netgear router in the basement, connected LAN port - LAN port to the Actiontec router, and connected the laptop to each router via RJ45 and wireless, and had no errors.

Connected computer upstairs to the Netgear router in the basement (which was still connected to the Actiontec router) and had no issues.

I probably conducted additional tests that I may have failed to mention, but at this point I am pretty sure the issue in the MoCA adapter. I am using this because I can't easuly get an RJ45 connection between the finished basement and the office upstairs.

Aside from a faulty MoCA device, is there any reason you can think of that I would result in corrupted file downloads (from google chrome, Mozilla Firefox, and IE Explorer) from multiple sites (www.sharpusa.com, www.lenovo.com, www.mozilla.com, etc.)?,

Any assistance would be appreciated.

Thank You,

Bryan
September 27, 2011 7:21:54 PM

Would it be worth purchasing a new MoCA adapter to see if it is the device?
September 28, 2011 12:06:29 AM

Have you tried another browser? Sometimes IE has trouble with EXEs and ZIPs when going through any sort of filtering
Related resources
September 29, 2011 7:47:28 PM

starzty said:
Have you tried another browser? Sometimes IE has trouble with EXEs and ZIPs when going through any sort of filtering


Hi- Yes, I tried Chrome, Firefox, Safari, and IE....

September 30, 2011 2:30:40 AM

Can you update the firmware in the MoCA? Could you get verizon to ship you another one to test? I can't think of any other steps to take
!