Sign in with
Sign up | Sign in
Your question

New Gaming Build Wont Boot Up! No Lights, Nothing Is Happening On The Motherboar

Tags:
  • New Build
  • Light
  • Boot
  • Systems
Last response: in Systems
Share
September 24, 2012 3:54:55 PM

Hi, I just got all my parts for my new build, but when i was finally done, It would refuse to boot up. No lights, nothing was happening on the motherboard. I'm pretty sure i got the front panel connectors in right and also have the power connectors on the board, so at least something should indicate that it works. Is this a safety thing that my motherboard does not let anything turn on until everything is plugged in? Here are my specs: Mobo: Gigabyte GA-Z68X-UD3H-B3 any my power supply is Thermaltake TR2 600W.

More about : gaming build wont boot lights happening motherboar

September 24, 2012 3:59:44 PM

1: make sure that the 2 power pins are aligned properly. mixing up the + and the - wont do anything
2:D id you even turn on your power supply
3: did you short the motherboard (mount the motherboard incorrectly)
4: uninstall the graphics card and use the intergrated for checking if its the graphics card

what are the other specs.need a full list
m
0
l
September 24, 2012 4:14:36 PM

My two power pins are aligned properly, i turned on the power supply, i put the motherboard correctly and i have not put in the graphics card because before i do that i want to see a indication that it works. My specs are: Mobo: Gigabyte GA-Z68X-UD3H-B3, PSU: Thermaltake TR2 600w, Intel i5 2500k, Zalman Z9 Plus Case, 1 Western Digital 500GB 7200rpm, 1 Western Digital 620GB 7200rpm, intel SSD 60GB, Coolmaster Hyper 212 Evo Cpu Cooler, Graphics Sapphire Radeon HD 7770 OC.
m
0
l
Related resources
!