Sign in with
Sign up | Sign in
Your question
Solved

3 Monitors, 570 GTX SLI, and 3d

Last response: in Graphics & Displays
Share
August 4, 2012 9:14:57 PM

I recently purchased a 120hz Nvidia 3d Vinson ready monitor (Acer GD235hz) to run with 2 60hz hp monitors (HP 2310e). I'm using 2x SLI 570 GTX cards and an 8400GS card to run one of the hp monitors. Whenever I enable SLI and open a game in 3d mode the picture goes in and out of focus every few seconds. In certain games like Metro 2033 I get an error message from Nvidia that reads "Warning: attempt to run in Stereoscopic 3d mode in non-stero display mode please chance to acceptable mode. See documentation for acceptable stereoscopic 3d mode." In other games like World of Warcraft it says 3d is enabled (and the 3d depth is raised) but the picture is in 2d mode. If I unplug the monitors or disable SLI 3d works perfectly. The Nvidia 3d test works no matter what configuration I use. I have the latest version of Nvidia's drives and 64-bit Windows 7 ultimate. Any ideas. Thanks.

More about : monitors 570 gtx sli

August 5, 2012 7:35:11 PM

NickOC said:
I recently purchased a 120hz Nvidia 3d Vinson ready monitor (Acer GD235hz) to run with 2 60hz hp monitors (HP 2310e). I'm using 2x SLI 570 GTX cards and an 8400GS card to run one of the hp monitors. Whenever I enable SLI and open a game in 3d mode the picture goes in and out of focus every few seconds. In certain games like Metro 2033 I get an error message from Nvidia that reads "Warning: attempt to run in Stereoscopic 3d mode in non-stero display mode please chance to acceptable mode. See documentation for acceptable stereoscopic 3d mode." In other games like World of Warcraft it says 3d is enabled (and the 3d depth is raised) but the picture is in 2d mode. If I unplug the monitors or disable SLI 3d works perfectly. The Nvidia 3d test works no matter what configuration I use. I have the latest version of Nvidia's drives and 64-bit Windows 7 ultimate. Any ideas. Thanks.


I'm confused, you have an 8400GS in your SLi? All cards in SLi should be nearly identical. ie. just 570's in SLi. As far as I know the 8400GS does not support 3D vision, meaning you need to plug up your other monitor to one of your 570's to get it to work.
m
0
l
August 5, 2012 10:27:29 PM

Thanks for the reply. I only use the 8499GS to run a third monitor since you need three cards in order to run 3 monitor while SLI is enabled. One of the 2d HP monitors is plugged into that monitor. My 3d monitor is connected to my top GTX 570 and my other HP monitor is connected to the bottom GTX 570. I'm using DVI cables for all of these by the way.
m
0
l
Related resources
August 5, 2012 10:42:09 PM

Please unbridge the 8800GS if you have done so.

Edit: make sure you have ONLY the 2 570's connected with an SLI bridge

Go to your settings in Nvidia display options and go into your "Set physx configuration"

Select 8800 GS to be your physx driver.

Have the 2 2D screens run off of your second 570

Problem solved.
m
0
l
August 6, 2012 1:26:58 AM

Really to prevent shuttering issues, he should completely remove the 8400 GS entirely.
Since both 570s have 2 DVI output ports he shouldn't have any trouble connecting all screens to them.

m
0
l
August 6, 2012 3:48:47 AM

One of the monitors needs to be plugged into the 8400GS if I have SLI enabled or I get a message that says "Up to 2 displays are supported by GPUs in SLI mode." If I keep one monitor plugged into the 8400GS and change the physx configuration I get the same error as before.

Note: An SLI bridge has never been connected tot he 8400GS only the GTX 570s.
Thanks.
m
0
l
August 6, 2012 4:05:48 AM

The problem with Metro 2033 seems to have resolved itself but now World of Warcraft displays the 3d picture with the same focus issue Metro had before.
m
0
l
August 6, 2012 5:31:37 PM

Can I ask if your using the latest drivers from Nvidia? Just the two 570s alone should be able to handle that config.
m
0
l
August 6, 2012 5:47:06 PM

Yes I am using the latest drivers. When I have maximize 3D performance enabled and try to plug all three monitors into the 507's I get an error that says "Up to 2 displays are supported by GPUs in SLI mode." Currently I have a few games working but I have to change the refresh rate (it doesn't matter what I change it to) and then tab in and out a few times. It doesn't work for every game and the game sit does work for only run at 60FPS even if the game is set to display at 120hz in the game settings as well as the Nvidia control panel.
m
0
l
August 6, 2012 6:09:24 PM

Tried configuring 3D surround? I know that the 600 series can have 4 displays connected to 1 card, so something has to be setup wrong. If you still are having trouble try uninstalling the 8400GS, reinstall the latest drivers with a "clean installation" that way it removes any old settings that could be messing you up.
m
0
l
August 6, 2012 6:15:24 PM

Wait a minute I just noticed you said your other two monitors are only 60hz? I'm not sure if that could be a problem with one being 120hz and the other two being 60hz, can you try using only 60hz screens and see if you still get the issue?
m
0
l
August 6, 2012 6:32:23 PM

I was thinking the same thing you were but the 60hz monitors are not 3d and the focus/flickering issue only happens with a 3d images.
m
0
l

Best solution

August 6, 2012 6:36:24 PM

It sounds kinda like the drivers are confused because 1 screen is natively 3d and the other 2 aren't. If your 3d works just fine with the 120hz screen only plugged in, then that most likely is your problem.

But to be sure please reinstall your drivers with a "clean install" and try it again.
Share
August 6, 2012 6:38:56 PM

Really in my opinion using a 3d emitter might be more ideal currently, until the market has more 3d screens to easily setup.
m
0
l
August 6, 2012 7:21:20 PM

Best answer selected by NickOC.
m
0
l
August 6, 2012 7:24:42 PM

The clean driver reinstall seems to have done the trick...still no 120fps but 60 still looks pretty smooth and even it I got the 120 working I don't think the cards would run that in many games on ultra with 3d enabled.
m
0
l
August 6, 2012 8:09:56 PM

Glad you got 60fps working with them good now, enjoy playing in 3D! :D 
m
0
l
August 7, 2012 6:00:46 AM

Thanks for the help!
m
0
l
!